Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

66 records

Priority LOW 29

The The Quiz and Survey Master (QSM) – Quiz Maker & Survey Maker plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 11.2.7.

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.0028 Published 2026-11-07 No fix listed CWE-94
Priority MEDIUM 40

Deserialization of Untrusted Data vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows Object Injection.This issue affects Quiz And Survey Master: from n/a through 11.2.7.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00352 Published 2026-10-19 No fix listed CWE-502
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows DOM-Based XSS.This issue affects Quiz And Survey Master: fr…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00166 Published 2026-10-12 No fix listed CWE-79
Priority LOW 31

The Quiz and Survey Master (QSM) – Quiz Maker & Survey Maker plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'qsm_hidden_questions' parameter in all versions up to, and including, 11.2…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00241 Published 2026-10-10 No fix listed CWE-79
Priority MEDIUM 40

Deserialization of Untrusted Data vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows Object Injection.This issue affects Quiz And Survey Master: from n/a through 11.2.7.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00279 Published 2026-10-09 No fix listed CWE-502
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows Stored XSS.This issue affects Quiz And Survey Master: from…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00127 Published 2026-10-07 No fix listed CWE-79
Priority LOW 30

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ExpressTech Quiz And Survey Master quiz-master-next allows DOM-Based XSS.This issue affects Quiz And Survey Master: fr…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00142 Published 2026-09-30 No fix listed CWE-79
Priority LOW 29

The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to generic SQL Injection via 'randon_category' Quiz Option in all versions up to, and including, 11.2.1 due to insufficient…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00451 Published 2026-08-16 No fix listed CWE-89
Priority LOW 29

The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'question_title' parameter in all versions up to, and including, 11.2.1 due to insuf…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00419 Published 2026-08-16 No fix listed CWE-79
Priority LOW 22

The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to time-based blind SQL Injection via the 'order' parameter in all versions up to, and including, 11.1.2 due to insufficien…

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.00352 Published 2026-06-05 No fix listed CWE-89
Priority LOW 28

The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to time-based SQL Injection via the ‘is_linking’ parameter in all versions up to, and including, 10.3.1 due to insufficient…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00258 Published 2026-01-06 No fix listed CWE-89
Priority LOW 28

The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to unauthorized access and modification of data due to a missing capability and status checks on multiple functions in all…

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00267 Published 2026-01-06 No fix listed CWE-862
Priority LOW 19

The Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the qsm_dashboard_delete_result function in all versions…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00225 Published 2026-01-06 No fix listed CWE-285
Priority MEDIUM 60

The Quiz and Survey Master (QSM) WordPress plugin before 9.2.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even w…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00339 Published 2025-03-25 Fixed in 9.2.1 CWE-79
Priority MEDIUM 55

The Quiz and Survey Master (QSM) WordPress plugin before 9.1.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even w…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00396 Published 2024-09-23 Fixed in 9.1.3 CWE-79
Priority MEDIUM 55

The Quiz and Survey Master (QSM) WordPress plugin before 9.1.1 fails to validate and escape certain Quiz fields before displaying them on a page or post where the Quiz is embedded, which could allows contributor and abov…

CVSS 3.1MEDIUM 4.7 Network No auth User interaction EPSS 0.00435 Published 2024-08-26 Fixed in 9.1.1 CWE-79
Priority MEDIUM 60

The Quiz and Survey Master (QSM) WordPress plugin before 9.1.0 does not properly sanitise and escape some of its Quizz settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scr…

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00329 Published 2024-08-03 Fixed in 9.1.0 CWE-79
Load more