Priority LOW 27
Converting crafted BIG-HKSCS input to UCS-4 or the internal wide character encoding, for example with iconv, in the GNU C Library version 2.18 through 2.31 may result in the converter making no progress, causing the call…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00446 · Published 2026-11-04 · No fix listed CWE-835
Priority LOW 33
The gettext family of functions in the GNU C Library version 2.0 and later accept LANGUAGE environment variable entries that contain '/' or that are equal to "..", unless the program is setuid or setgid (AT_SECURE).
CVSS 3.1HIGH 7.0· Local · Low privileges · No interaction · EPSS 0.00297 · Published 2026-10-30 · No fix listed CWE-22
Priority LOW 27
GNU mtools before 4.0.50 has an out-of-bounds write in parse_vses in vfat.c.
CVSS 3.1MEDIUM 6.1· Local · No auth · User interaction · EPSS 0.0032 · Published 2026-10-28 · Partial fix · 4.0.50 CWE-839
Priority LOW 23
UnRTF by GNU Project is vulnerable to out-of-bounds write.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00207 · Published 2026-10-20 · Fixed in 0.21.12 CWE-787
Priority LOW 29
GNU LibreDWG through 0.14.8612 contains a global out-of-bounds read vulnerability in the AcDs decoder acds_private() that allows attackers to read beyond a static table via an unchecked schema property type index.
CVSS 4.0MEDIUM 6.9· Local · No auth · User interaction · EPSS 0.00129 · Published 2026-10-15 · No fix listed CWE-125
Priority MEDIUM 60
GNU Aspell 0.60.8.2 (first vulnerable version is not known) contains a heap-based buffer overflow write (CWE-122) in its read-only dictionary loader.
CVSS 3.1MEDIUM 5.9· Local · No auth · No interaction · EPSS 0.00213 · Published 2026-10-12 · Partial fix CWE-122
Priority LOW 37
GNU Emacs before 31.2 (and TRAMP through 2.8.2) allows OS command injection via a filename because tramp-user-regexp has an incomplete list of disallowed inputs.
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00647 · Published 2026-10-11 · Partial fix · 31.2 CWE-184
Priority LOW 9
GNU Aspell contains an integer truncation vulnerability in the WritableDict::add() function in modules/speller/default/writable.cpp.
CVSS 4.0LOW 1.8· Local · No auth · User interaction · EPSS 0.00132 · Published 2026-10-06 · Partial fix · 0.60.8.3 CWE-190
Priority LOW 9
GNU Aspell contains an out-of-bounds read vulnerability in ReadOnlyDict::load() in readonly_ws.cpp.
CVSS 4.0LOW 1.8· Local · No auth · User interaction · EPSS 0.00125 · Published 2026-10-06 · Partial fix · 0.60.8.3 CWE-125
Priority LOW 9
GNU Aspell prezip-bin contains a heap-based buffer overflow vulnerability in the decompressor in prog/prezip.c.
CVSS 4.0LOW 1.8· Local · No auth · User interaction · EPSS 0.00146 · Published 2026-10-06 · Partial fix · 0.60.8.3 CWE-122
Priority LOW 29
A local attacker with control over GRUB's configuration can bypass lockdown restrictions when booting with Secure Boot and load an unsigned GRUB module, while GRUB continues to report lockdown is enabled.
CVSS 3.1MEDIUM 6.4· Local · High privileges · No interaction · EPSS 0.00115 · Published 2026-10-02 · Partial fix · 2.16 CWE-822
Priority LOW 17
The strncasecmp function in the GNU C Library 2.24 and later optimized for the Power8 architecture may read one byte beyond the input size limit, which may crash a program when that byte is not readable.
CVSS 3.1LOW 3.7· Network · No auth · No interaction · EPSS 0.00281 · Published 2026-09-28 · Partial fix · 2.45 CWE-126
Priority HIGH 67
GNU libextractor before 1.16 loads plugins from an untrusted search path specified by the LIBEXTRACTOR_PREFIX environment variable without proper privilege checks.
CVSS 4.0HIGH 7.3· Local · Low privileges · No interaction · EPSS 0.00137 · Published 2026-09-25 · Fixed in 1.16 CWE-426
Priority LOW 34
GNU Emacs 28.1 through 31.1 allows arbitrary code execution upon opening a file, because an untrusted value of read-symbol-shorthands affects the intern and unintern functions.
CVSS 4.0HIGH 7.5· Local · No auth · No interaction · EPSS 0.00142 · Published 2026-09-22 · Fixed CWE-829
Priority LOW 16
A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs.
CVSS 3.1LOW 3.6· Local · Low privileges · No interaction · EPSS 0.00102 · Published 2026-09-22 · Partial fix · 2.45 CWE-121
Priority LOW 29
A time-of-check to time-of-use (TOCTOU) race condition in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to escalate privileges.
CVSS 3.1MEDIUM 6.3· Local · Low privileges · User interaction · EPSS 0.00097 · Published 2026-09-22 · Partial fix · 2.45 CWE-367
Priority LOW 24
Initializing the DNS stub resolver from an /etc/resolv.conf file, or a LOCALDOMAIN environment variable, whose search list contains a domain of roughly 200 characters or more in the GNU C Library version 2.26 to 2.44 res…
CVSS 3.1MEDIUM 5.3· Adjacent network · No auth · No interaction · EPSS 0.00315 · Published 2026-09-17 · Partial fix CWE-617
Priority LOW 26
Converting crafted EUC_JISX0213 input to UCS-4 or the internal wide character encoding, for example with iconv, in the GNU C Library version 2.3 to 2.44 may result in the converter making no progress, causing the calling…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00358 · Published 2026-09-15 · Partial fix CWE-835
Priority LOW 26
Converting crafted SHIFT_JISX0213 input to UCS-4 or the internal wide character encoding, for example with iconv, in the GNU C Library version 2.3 to 2.44 may result in the converter making no progress, causing the calli…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00358 · Published 2026-09-15 · Partial fix CWE-835
Priority MEDIUM 55
A vulnerability was detected in GNU Binutils 2.47.
CVSS 4.0MEDIUM 4.8· Local · Low privileges · No interaction · EPSS 0.00175 · Published 2026-09-15 · Fixed in 2.48 CWE-404
Priority MEDIUM 55
A security vulnerability has been detected in GNU Binutils 2.47.
CVSS 4.0MEDIUM 4.8· Local · Low privileges · No interaction · EPSS 0.00175 · Published 2026-09-15 · Fixed in 2.48 CWE-404
Priority MEDIUM 55
A weakness has been identified in GNU Binutils 2.47.
CVSS 4.0MEDIUM 4.8· Local · Low privileges · No interaction · EPSS 0.0017 · Published 2026-09-15 · Fixed CWE-404
Priority MEDIUM 55
A security flaw has been discovered in GNU Binutils 2.47.
CVSS 4.0MEDIUM 4.8· Local · Low privileges · No interaction · EPSS 0.0017 · Published 2026-09-15 · Fixed CWE-404
Priority HIGH 77
GNU libextractor before 1.15 contains a stack-based buffer overflow vulnerability in the process_star_office function that sizes a variable-length stack array from attacker-controlled OLE2 stream data.
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.0074 · Published 2026-09-15 · Fixed in 1.15 CWE-789
Priority LOW 21
A vulnerability was detected in GNU Binutils 2.47.
CVSS 4.0MEDIUM 4.8· Local · Low privileges · No interaction · EPSS 0.00168 · Published 2026-09-14 · Partial fix CWE-119
Load more