Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

57 records

TI-2024-21804 CVE-2024-32937 · GHSA-6x56-7q94-5745

OS command injection in Grandstream GXP2135

Priority HIGH 65

An os command injection vulnerability exists in the CWMP SelfDefinedTimeZone functionality of Grandstream GXP2135 1.0.9.129, 1.0.11.74 and 1.0.11.79.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.26958 Published 2024-07-03 No fix listed CWE-78
Priority MEDIUM 42

The Grandstream UCM Series IP PBX before firmware version 1.0.20.52 is affected by a parameter injection vulnerability in the HTTP interface.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.0088 Published 2024-04-29 Fixed in <1.0.20.52 CWE-141
Priority MEDIUM 51

In Grandstream GSD3710 in its 1.0.11.13 version, it's possible to overflow the stack since it doesn't check the param length before using the sscanf instruction.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0584 Published 2022-09-23 No fix listed CWE-121
Priority MEDIUM 57

an attacker with knowledge of user/pass of Grandstream GSD3710 in its 1.0.11.13 version, could overflow the stack since it doesn't check the param length before use the strcopy instruction.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0545 Published 2022-09-23 No fix listed CWE-121
Priority MEDIUM 48

Multiple buffer overflows in the limited configuration shell (/sbin/gs_config) on Grandstream HT801 devices before 1.0.29 allow remote authenticated users to execute arbitrary code as root via a crafted manage_if setting…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.07408 Published 2021-10-28 No fix listed CWE-787
Priority LOW 39

Grandstream HT800 series firmware version 1.0.17.5 and below is vulnerable to a denial of service attack against the TR-069 service.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.03361 Published 2020-07-29 No fix listed CWE-476
TI-2020-04689 CVE-2020-5761 · GHSA-9wp9-6795-j8rm

Infinite loop in Grandstream HT800 Series

Priority MEDIUM 40

Grandstream HT800 series firmware version 1.0.17.5 and below is vulnerable to CPU exhaustion due to an infinite loop in the TR-069 service.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.04093 Published 2020-07-29 No fix listed CWE-835
Priority MEDIUM 42

Grandstream HT800 series firmware version 1.0.17.5 and below is vulnerable to an OS command injection vulnerability.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.0547 Published 2020-07-29 No fix listed CWE-78
Priority MEDIUM 48

Grandstream UCM6200 series firmware version 1.0.20.23 and below is vulnerable to OS command injection via SSH.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03204 Published 2020-07-17 No fix listed CWE-78
Priority MEDIUM 45

Grandstream UCM6200 series firmware version 1.0.20.23 and below is vulnerable to OS command injection via HTTP.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04375 Published 2020-07-17 No fix listed CWE-78
Priority MEDIUM 52

Grandstream UCM6200 series firmware version 1.0.20.23 and below is vulnerable to OS command injection via HTTP.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.06926 Published 2020-07-17 No fix listed CWE-78
Priority MEDIUM 43

Grandstream GWN7000 firmware version 1.0.9.4 and below allows authenticated remote users to modify the system's crontab via undocumented API.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.02473 Published 2020-07-17 No fix listed CWE-489
Priority MEDIUM 46

Grandstream GXP1600 series firmware 1.0.4.152 and below is vulnerable to authenticated remote command execution when an attacker adds an OpenVPN up script to the phone's VPN settings via the "Additional Settings" field i…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.05339 Published 2020-04-14 No fix listed CWE-94
Priority MEDIUM 46

Grandstream GXP1600 series firmware 1.0.4.152 and below is vulnerable to authenticated remote command execution when an attacker uploads a specially crafted tar file to the HTTP /cgi-bin/upload_vpntar interface.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.05424 Published 2020-04-14 No fix listed CWE-59
Priority MEDIUM 40

The Grandstream UCM6200 series before 1.0.20.22 is vulnerable to an SQL injection via the CTI server on port 8888.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.04332 Published 2020-03-30 No fix listed CWE-89
Priority LOW 30

The Grandstream UCM6200 series before 1.0.20.22 is vulnerable to an SQL injection via the HTTP server's websockify endpoint.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.01752 Published 2020-03-30 No fix listed CWE-89
Load more