Priority LOW 38
iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker to execute arbitrary commands with the privileges of the logged-in user by inducing the user to open a…
CVSS 4.0HIGH 8.7· Network · No auth · User interaction · EPSS 0.00475 · Published 2026-11-05 · Fixed in 3.7.7beta2 CWE-88
Priority HIGH 69
In iTerm2 through 3.6.9, displaying a .txt file can cause code execution via DCS 2000p and OSC 135 data, if the working directory contains a malicious file whose name is valid output from the conductor encoding path, suc…
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.00199 · Published 2026-04-18 · No fix listed CWE-829
Priority MEDIUM 47
iTerm2 3.5.6 through 3.5.10 before 3.5.11 sometimes allows remote attackers to obtain sensitive information from terminal commands by reading the /tmp/framer.txt file.
CVSS 3.1CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.00494 · Published 2025-01-03 · Fixed in 3.5.11 CWE-532
Priority HIGH 82
An issue was discovered in iTerm2 3.5.x before 3.5.2.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01683 · Published 2024-06-16 · No fix listed CWE-94
Priority MEDIUM 52
In iTerm2 before 3.5.2, the "Terminal may report window title" setting is not honored, and thus remote code execution might occur but "is not trivially exploitable."
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01484 · Published 2024-06-16 · No fix listed CWE-94
Priority MEDIUM 50
iTermSessionLauncher.m in iTerm2 before 3.5.0beta12 does not sanitize ssh hostnames in URLs.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00817 · Published 2023-10-22 · No fix listed CWE-117
Priority MEDIUM 50
iTermSessionLauncher.m in iTerm2 before 3.5.0beta12 does not sanitize paths in x-man-page URLs.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00817 · Published 2023-10-22 · No fix listed CWE-117
Priority HIGH 82
iTerm2 before 3.4.20 allow (potentially remote) code execution because of mishandling of certain escape sequences related to upload.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01319 · Published 2023-10-22 · No fix listed CWE-116
Priority HIGH 82
iTerm2 before 3.4.20 allow (potentially remote) code execution because of mishandling of certain escape sequences related to tmux integration.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01319 · Published 2023-10-22 · No fix listed CWE-116
Priority MEDIUM 51
iTerm2 before 3.4.18 mishandles a DECRQSS response.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0096 · Published 2022-11-23 · No fix listed CWE-20
Priority LOW 36
iTerm2 through 3.3.6 has potentially insufficient documentation about the presence of search history in com.googlecode.iterm2.plist, which might allow remote attackers to obtain sensitive information, as demonstrated by…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01421 · Published 2019-11-17 · No fix listed CWE-200
Priority MEDIUM 47
A vulnerability exists in the way that iTerm2 integrates with tmux's control mode, which may allow an attacker to execute arbitrary commands by providing malicious output to the terminal.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02459 · Published 2019-10-09 · No fix listed CWE-349
Priority LOW 37
iTerm2 3.x before 3.1.1 allows remote attackers to discover passwords by reading DNS queries.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.0223 · Published 2017-09-20 · No fix listed CWE-200