Priority LOW 22
The Custom 404 Pro plugin for WordPress is vulnerable to time-based SQL Injection via the ‘path’ parameter in all versions up to, and including, 3.12.0 due to insufficient escaping on the user supplied parameter and lack…
CVSS 3.1MEDIUM 4.9· Network · High privileges · No interaction · EPSS 0.00296 · Published 2025-10-11 · No fix listed CWE-89
Priority LOW 32
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kunal Custom 404 Pro custom-404-pro.This issue affects Custom 404 Pro: from n/a through <= 3.11.1.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00624 · Published 2024-08-01 · No fix listed CWE-79
Priority LOW 31
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kunal Nagar Custom 404 Pro allows Stored XSS.This issue affects Custom 404 Pro: from n/a through 3.10.0.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00351 · Published 2024-02-01 · No fix listed CWE-79
Priority LOW 27
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Kunal Nagar Custom 404 Pro plugin <= 3.8.1 versions.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0034 · Published 2023-08-30 · No fix listed CWE-79
Priority HIGH 82
The Custom 404 Pro WordPress plugin before 3.8.1 does not properly sanitize database inputs, leading to multiple SQL Injection vulnerabilities.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00934 · Published 2023-06-27 · Fixed in 3.8.1
Priority MEDIUM 60
The Custom 404 Pro WordPress plugin before 3.7.3 does not escape some URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0171 · Published 2023-05-30 · Fixed in 3.7.3 CWE-79
Priority LOW 39
Auth. SQL Injection') vulnerability in Kunal Nagar Custom 404 Pro plugin <= 3.7.0 versions.
CVSS 3.1HIGH 8.3· Network · High privileges · User interaction · EPSS 0.00668 · Published 2023-04-12 · No fix listed CWE-89
Priority LOW 20
The Custom 404 Pro plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.7.1.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00331 · Published 2023-01-18 · No fix listed CWE-352
Priority LOW 29
The custom-404-pro plugin before 3.2.8 for WordPress has reflected XSS, a different vulnerability than CVE-2019-14789.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0095 · Published 2019-08-30 · No fix listed CWE-79
Priority LOW 30
The Custom 404 Pro plugin 3.2.8 for WordPress has XSS via the wp-admin/admin.php?page=c4p-main page parameter.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01611 · Published 2019-08-15 · No fix listed CWE-79