Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

8 records

Priority LOW 24

The Related Posts for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2.1.

CVSS 3.1MEDIUM 5.4 Network No auth User interaction EPSS 0.00283 Published 2024-03-13 No fix listed CWE-352
Priority LOW 23

The Related Posts for WordPress plugin through 2.0.4 does not sanitise its heading_text and CSS settings, allowing high privilege users (admin) to set XSS payloads in them, leading to Stored Cross-Site Scripting issues.

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00687 Published 2021-07-19 No fix listed CWE-79
Priority LOW 25

Unvalidated input and lack of output encoding within the Related Posts for WordPress plugin before 2.0.4 lead to a Reflected Cross-Site Scripting (XSS) vulnerability within the 'lang' GET parameter while editing a post,…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00632 Published 2021-04-05 Fixed in 2.0.4 CWE-79