Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

9 records

TI-2020-03543 CVE-2020-4054 · GHSA-p4x4-rw2p-8j8m

Cross-site Scripting in Sanitize

Priority LOW 36

In Sanitize (RubyGem sanitize) greater than or equal to 3.0.0 and less than 5.2.1, there is a cross-site scripting vulnerability.

CVSS 3.1HIGH 7.3 Network No auth No interaction EPSS 0.01917 Published 2020-06-16 Fixed in 5.2.1 CWE-79
Priority LOW 36

A specially crafted HTML fragment can cause Sanitize gem for Ruby to allow non-whitelisted attributes to be used on a whitelisted HTML element.

CVSS 3.0HIGH 7.5 Network No auth No interaction EPSS 0.01468 Published 2018-03-30 Fixed in 4.6.3 CWE-79