Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

25 records

TI-2010-04013 CVE-2010-4264 · GHSA-94c2-rg8m-c4ch

Cross-site scripting in vanilla forums

Priority LOW 28

It was found in vanilla forums before 2.0.10 a cross-site scripting vulnerability where a filename could contain arbitrary code to execute on the client side.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00661 Published 2021-06-22 No fix listed CWE-79
Priority LOW 26

Multiple stored XSS in Vanilla Forums before 2.5 allow remote attackers to inject arbitrary JavaScript code into any message on forum.

CVSS 3.0MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00806 Published 2019-03-02 Fixed in 2.5 CWE-79
Priority LOW 31

Vanilla before 2.6.1 allows SQL injection via an invitationID array to /profile/deleteInvitation, related to applications/dashboard/models/class.invitationmodel.php and applications/dashboard/controllers/class.profilecon…

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.0094 Published 2018-09-03 No fix listed CWE-89
Priority LOW 22

In Vanilla before 2.6.1, the polling functionality allows Insecure Direct Object Reference (IDOR) via the Poll ID, leading to the ability of a single user to select multiple Poll Options (e.g., vote for multiple items).

CVSS 3.0MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00878 Published 2018-08-26 No fix listed CWE-639
Priority LOW 19

The edit-profile page in Vanilla Forums before 2.1a32 allows remote authenticated users to modify arbitrary profile settings by replacing the UserID value during a man-in-the-middle attack, related to a "parameter manipu…

CVSS 2.0LOW 3.5 Network Low privileges Interaction — EPSS 0.01067 Published 2012-11-15 No fix listed CWE-264
Priority LOW 25

Vanilla 2.0.16 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by plugins/Minify/min/utils.php and cer…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.01229 Published 2011-09-24 No fix listed CWE-200
Priority LOW 22

Cross-site scripting (XSS) vulnerability in Vanilla Forums before 2.0.17.6 allows remote attackers to inject arbitrary web script or HTML via the p parameter to an unspecified component, a different vulnerability than CV…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.00855 Published 2011-02-08 No fix listed CWE-79
Priority LOW 28

Open redirect vulnerability in Vanilla Forums before 2.0.17.6 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the Target parameter to an unspecified component, a…

CVSS 2.0MEDIUM 5.8 Network No auth Interaction — EPSS 0.00959 Published 2011-02-08 No fix listed CWE-20