Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

5 records

Priority LOW 25

The WP-Polls plugin for WordPress is vulnerable to SQL Injection via COOKIE in all versions up to, and including, 2.77.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on t…

CVSS 3.1MEDIUM 5.4 Network No auth No interaction EPSS 0.00491 Published 2025-01-22 No fix listed CWE-89
TI-2022-01452 CVE-2022-1581 · GHSA-27qm-jwxp-8whw

WP-Polls < 2.76.0 - IP Validation Bypass

Priority MEDIUM 57

The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00698 Published 2022-11-21 Fixed in 2.76.0