Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

7 records

Priority LOW 22

The YARPP – Yet Another Related Posts Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to and including 5.30.9 due to insufficient input sanitization and outp…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00263 Published 2024-06-19 No fix listed CWE-79
Priority LOW 21

The YARPP – Yet Another Related Posts Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 5.30.9 due to insufficient input sanitization and ou…

CVSS 3.1MEDIUM 4.4 Network High privileges No interaction EPSS 0.00512 Published 2024-02-20 No fix listed CWE-79
Priority HIGH 73

The YARPP WordPress plugin before 5.30.3 does not validate and escape some of its shortcode attributes before using them in SQL statement/s, which could allow any authenticated users, such as subscribers to perform SQL I…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.0094 Published 2023-08-16 Fixed in 5.30.3 CWE-89
Priority LOW 29

The YARPP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'className' parameter in versions up to, and including, 5.30.3 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0051 Published 2023-07-18 No fix listed CWE-79
Priority HIGH 65

The YARPP WordPress plugin before 5.30.3 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor…

CVSS 3.1MEDIUM 6.8 Network High privileges User interaction EPSS 0.00707 Published 2023-02-13 Fixed in 5.30.3