Red Hat Security AdvisoryRHSA-2013:0638
Red Hat OpenShift Enterprise 1.1.2 update
Released 2013-03-12 · Red Hat rating Moderate · View on Red Hat →
Fixed in
- Red Hat OpenShift Enterprise Infrastructure ruby193-rubygem-rack-1:1.4.1-4.el6, rubygem-rack-1:1.3.0-4.el6op
- Red Hat OpenShift Enterprise Node jenkins-1.502-1.el6op, openshift-origin-cartridge-jenkins-1.4-1.0.3-1.el6op, ruby193-rubygem-rack-1:1.4.1-4.el6 +1
Fixes 7 records
Priority LOW 37
Unspecified vulnerability in Jenkins before 1.502 and LTS before 1.480.3 allows remote attackers to bypass the CSRF protection mechanism via unknown attack vectors.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02309 · Published 2013-03-19 · Fixed in 1.502, 1.480.3 CWE-352
Priority LOW 36
Cross-site request forgery (CSRF) vulnerability in Jenkins master in Jenkins before 1.502 and LTS before 1.480.3 allows remote attackers to hijack the authentication of users via unknown vectors.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.03306 · Published 2013-03-19 · Fixed in 1.502, 1.480.3 CWE-352
Priority LOW 32
Rack::Session::Cookie in Rack 1.5.x before 1.5.2, 1.4.x before 1.4.5, 1.3.x before 1.3.10, 1.2.x before 1.2.8, and 1.1.x before 1.1.6 allows remote attackers to guess the session cookie, gain privileges, and execute arbi…
CVSS 2.0MEDIUM 5.1· Network · No auth · Interaction — · EPSS 0.05383 · Published 2013-02-08 · Partial fix · 1.5.2, 1.4.5 +3
Priority LOW 25
rack/file.rb (Rack::File) in Rack 1.5.x before 1.5.2 and 1.4.x before 1.4.5 allows attackers to access arbitrary files outside the intended root directory via a crafted PATH_INFO environment variable, probably a director…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.02941 · Published 2013-02-08 · Fixed in 1.5.2, 1.4.5 CWE-22
Priority LOW 23
Jenkins before 1.502 and LTS before 1.480.3 allows remote authenticated users with write access to cause a denial of service via a crafted payload.
CVSS 2.0MEDIUM 4.0· Network · Low privileges · Interaction — · EPSS 0.02003 · Published 2013-03-19 · Fixed in 1.502, 1.480.3 CWE-20
Priority LOW 23
Cross-site scripting (XSS) vulnerability in Jenkins before 1.502 and LTS before 1.480.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01301 · Published 2013-03-19 · Fixed in 1.502 CWE-352
Priority LOW 22
Unspecified vulnerability in Jenkins before 1.502 and LTS before 1.480.3 allows remote authenticated users with write access to build arbitrary jobs via unknown attack vectors.
CVSS 2.0MEDIUM 4.0· Network · Low privileges · Interaction — · EPSS 0.01762 · Published 2013-03-19 · Fixed in 1.502, 1.480.3 CWE-284