Red Hat Security AdvisoryRHSA-2015:1844
Red Hat OpenShift Enterprise 2.2.7 security, bug fix and enhancement update
Released 2015-09-30 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat OpenShift Enterprise Client 2.2 rhc-1.37.1.2-1.el6op
- Red Hat OpenShift Enterprise Infrastructure 2.2 openshift-origin-broker-1.16.2.10-1.el6op, openshift-origin-broker-util-1.36.2.2-1.el6op, openshift-origin-logshifter-1.10.1.2-1.el6op +5
- Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 openshift-origin-cartridge-jbosseap-2.26.3.1-1.el6op
- Red Hat OpenShift Enterprise Node 2.2 jenkins-1.609.1-1.el6op, openshift-origin-cartridge-diy-1.26.1.1-1.el6op, openshift-origin-cartridge-haproxy-1.30.1.1-1.el6op +12
Fixes 9 records
Priority LOW 37
The API token-issuing service in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to gain privileges via a "forced API token change" involving anonymous users.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02346 · Published 2015-10-16 · Fixed in 1.606, 1.596.2 CWE-264
Priority LOW 36
XML external entity (XXE) vulnerability in CloudBees Jenkins before 1.600 and LTS before 1.596.1 allows remote attackers to read arbitrary XML files via a crafted XML document.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01414 · Published 2020-01-15 · Fixed in 1.600, 1.596.1 CWE-611
Priority LOW 36
XML external entity (XXE) vulnerability in CloudBees Jenkins before 1.600 and LTS before 1.596.1 allows remote attackers to read arbitrary XML files via an XPath query.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01414 · Published 2020-01-15 · Fixed in 1.600, 1.596.1 CWE-611
Priority LOW 34
The combination filter Groovy script in Jenkins before 1.600 and LTS before 1.596.1 allows remote authenticated users with job configuration permission to gain privileges and execute arbitrary code on the master via unsp…
CVSS 2.0MEDIUM 6.5· Network · Low privileges · Interaction — · EPSS 0.02523 · Published 2015-10-16 · Fixed in 1.600, 1.596.1 CWE-264
Priority LOW 24
Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1812…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01769 · Published 2015-10-16 · Fixed in 1.606, 1.596.2 CWE-79
Priority LOW 24
Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1813…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01769 · Published 2015-10-16 · Fixed in 1.596.2, 1.606 CWE-79
Priority LOW 24
The HudsonPrivateSecurityRealm class in Jenkins before 1.600 and LTS before 1.596.1 does not restrict access to reserved names when using the "Jenkins' own user database" setting, which allows remote attackers to gain pr…
CVSS 2.0MEDIUM 4.6· Network · Low privileges · Interaction — · EPSS 0.01569 · Published 2015-10-16 · Fixed in 1.600, 1.596.1 CWE-264
Priority LOW 20
Jenkins before 1.600 and LTS before 1.596.1 allows remote authenticated users to cause a denial of service (improper plug-in and tool installation) via crafted update center data.
CVSS 2.0LOW 3.5· Network · Low privileges · Interaction — · EPSS 0.01577 · Published 2015-10-16 · Fixed in 1.600, 1.596.1 CWE-20
Priority LOW 20
Directory traversal vulnerability in Jenkins before 1.600 and LTS before 1.596.1 allows remote authenticated users with certain permissions to read arbitrary files via a symlink, related to building artifacts.
CVSS 2.0LOW 3.5· Network · Low privileges · Interaction — · EPSS 0.01812 · Published 2015-10-16 · Fixed CWE-22