XML external entity injection in CloudBees Jenkins
Priority LOW 36CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-611 and the CVSS impact.
Summary
XML external entity (XXE) vulnerability in CloudBees Jenkins before 1.600 and LTS before 1.596.1 allows remote attackers to read arbitrary XML files via a crafted XML document.
Why it matters now
EPSS 0.01414 72nd percentileScored 2026-11-07
Fix Fixed Jenkins (CloudBees): 1.600Jenkins LTS (CloudBees): 1.596.1+1 more productRed Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CloudBees | Jenkins | before 1.600 | 1.600 | Patch available | CNA |
| CloudBees | Jenkins LTS | before 1.596.1 | 1.596.1 | Patch available | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.597 to before 1.600 | 1.600 | Patch available | GHSA-qg7x-4h4q-3m49 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.596.1 | 1.596.1 | Patch available | GHSA-qg7x-4h4q-3m49 |
- Jenkins VendorCloudBees Affected before 1.600 Fixed in 1.600 Patch available CNA
- Jenkins LTS VendorCloudBees Affected before 1.596.1 Fixed in 1.596.1 Patch available CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.597 to before 1.600 Fixed in 1.600 Patch available GHSA-qg7x-4h4q-3m49
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.596.1 Fixed in 1.596.1 Patch available GHSA-qg7x-4h4q-3m49
Remediation
- Fix · CNA Jenkins (CloudBees) Fixed in 1.600
- Fix · CNA Jenkins LTS (CloudBees) Fixed in 1.596.1
- Fix · GHSA-qg7x-4h4q-3m49 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.600 Advisory →
- Fix · GHSA-qg7x-4h4q-3m49 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.596.1 Advisory →
Red Hat 1 advisory
- RHSA-2015:1844 Released 2015-09-30 · Red Hat rating ImportantRed Hat OpenShift Enterprise 2.2.7 security, bug fix and enhancement update
- Red Hat OpenShift Enterprise Client 2.2 rhc-1.37.1.2-1.el6op
- Red Hat OpenShift Enterprise Infrastructure 2.2 openshift-origin-broker-1.16.2.10-1.el6op, openshift-origin-broker-util-1.36.2.2-1.el6op, openshift-origin-logshifter-1.10.1.2-1.el6op +5
- Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 openshift-origin-cartridge-jbosseap-2.26.3.1-1.el6op
- Red Hat OpenShift Enterprise Node 2.2 jenkins-1.609.1-1.el6op, openshift-origin-cartridge-diy-1.26.1.1-1.el6op, openshift-origin-cartridge-haproxy-1.30.1.1-1.el6op +12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise Client 2.2 | Fixed | RHSA-2015:1844 |
| Red Hat OpenShift Enterprise Infrastructure 2.2 | Fixed | RHSA-2015:1844 |
| Red Hat OpenShift Enterprise JBoss EAP add-on 2.2 | Fixed | RHSA-2015:1844 |
| Red Hat OpenShift Enterprise Node 2.2 | Fixed | RHSA-2015:1844 |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-1811
- 2026-10-03 Alias added: GHSA-qg7x-4h4q-3m49
References
More CloudBees vulnerabilities
- TI-2019-08474 CloudBees Jenkins Operations Center 2.150.2.3, when an expired trial license exists… CVSS 3.0CRITICAL 9.8
- TI-2012-00722 Uncontrolled resource consumption in Jenkins CVSS 3.1HIGH 7.5
- TI-2015-01626 XML external entity injection in CloudBees Jenkins CVSS 3.1HIGH 7.5
- TI-2013-01805 Multiple cross-site request forgery (CSRF) vulnerabilities in Jenkins before 1.514, LTS… CVSS 2.0MEDIUM 6.8
- TI-2012-05037 Open redirect vulnerability in Jenkins before 1.491, Jenkins LTS before 1.480.1, and… CVSS 2.0MEDIUM 5.8
- TI-2012-05036 CRLF injection vulnerability in Jenkins before 1.491, Jenkins LTS before 1.480.1, and… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2015-1811 · CVE Program
- CVE-2015-1811 · NVD
- FIRST EPSS
- GHSA-qg7x-4h4q-3m49 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-1811 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences