Red Hat Security AdvisoryRHSA-2016:0489
Red Hat OpenShift Enterprise 2.2.9 security, bug fix, and enhancement update
Released 2016-03-22 · Red Hat rating Important · View on Red Hat →
Fixes 15 records
Priority CRITICAL 90KEV
The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote attackers to obtain sensitive job and build name information via a direct request.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.23003 · Published 2015-11-25 · Fixed in 1.625.2, 1.638 CWE-200
Priority CRITICAL 85
The Jenkins CLI subsystem in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to execute arbitrary code via a crafted serialized Java object, related to a problematic webapps/ROOT/WEB-INF/lib/commons-c…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.91865 · Published 2015-11-25 · Fixed in 1.625.2, 1.638 CWE-502
Priority HIGH 69
Apache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to execute arbitrary code via a crafted serialized Java Message Service (JMS) ObjectMess…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.38191 · Published 2016-01-08 · Partial fix · 5.11.3, 5.12.2 CWE-20
Priority MEDIUM 43
Cross-site request forgery (CSRF) vulnerability in Jenkins before 1.640 and LTS before 1.625.2 allows remote attackers to hijack the authentication of administrators for requests that have unspecified impact via vectors…
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.02395 · Published 2016-02-03 · Fixed in 1.640, 1.625.2 CWE-352
Priority MEDIUM 42
Jenkins before 1.640 and LTS before 1.625.2 allow remote attackers to bypass the CSRF protection mechanism via unspecified vectors.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.02222 · Published 2016-02-03 · Fixed in 1.640, 1.625.2 CWE-352
Priority LOW 36
The Plugins Manager in Jenkins before 1.640 and LTS before 1.625.2 does not verify checksums for plugin files referenced in update site data, which makes it easier for man-in-the-middle attackers to execute arbitrary cod…
CVSS 3.0HIGH 7.5· Network · No auth · User interaction · EPSS 0.01397 · Published 2016-02-03 · Fixed in 1.625.2, 1.640 CWE-345
Priority LOW 36
Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slave.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01787 · Published 2015-11-25 · Fixed in 1.625.2, 1.638 CWE-284
Priority LOW 32
Jenkins before 1.638 and LTS before 1.625.2 do not properly restrict access to API tokens which might allow remote administrators to gain privileges and run scripts by using an API token of another user.
CVSS 2.0MEDIUM 6.5· Network · Low privileges · Interaction — · EPSS 0.01491 · Published 2015-11-25 · Fixed in 1.625.2, 1.638 CWE-264
Priority LOW 32
Jenkins before 1.638 and LTS before 1.625.2 uses a publicly accessible salt to generate CSRF protection tokens, which makes it easier for remote attackers to bypass the CSRF protection mechanism via a brute force attack.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01155 · Published 2015-11-25 · Fixed in 1.625.2, 1.638 CWE-352
Priority LOW 29
Directory traversal vulnerability in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to list directory contents and read arbitrary files in the Jenkins servlet resources via directory traversal sequen…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.03156 · Published 2015-11-25 · Fixed in 1.638, 1.625.2 CWE-22
Priority LOW 27
Jenkins before 1.638 and LTS before 1.625.2 allow remote attackers to obtain sensitive information via a direct request to queue/api.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.02064 · Published 2015-11-25 · Fixed in 1.638, 1.625.2 CWE-264
Priority LOW 27
The sidepanel widgets in the CLI command overview and help pages in Jenkins before 1.638 and LTS before 1.625.2 allow remote attackers to obtain sensitive information via a direct request to the pages.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.02064 · Published 2015-11-25 · Fixed in 1.638, 1.625.2 CWE-200
Priority LOW 27
Jenkins before 1.638 and LTS before 1.625.2 do not properly verify the shared secret used in JNLP slave connections, which allows remote attackers to connect as slaves and obtain sensitive information or possibly gain ad…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.02122 · Published 2015-11-25 · Fixed in 1.638, 1.625.2 CWE-200
Priority LOW 27
XML external entity (XXE) vulnerability in the create-job CLI command in Jenkins before 1.638 and LTS before 1.625.2 allows remote attackers to read arbitrary files via a crafted job configuration that is then used in an…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.02336 · Published 2015-11-25 · Fixed in 1.638, 1.625.2 CWE-611
Priority LOW 24
Cross-site scripting (XSS) vulnerability in the slave overview page in Jenkins before 1.638 and LTS before 1.625.2 allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via the…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01786 · Published 2015-11-25 · Fixed in 1.625.2, 1.638 CWE-79