Red Hat Security AdvisoryRHSA-2017:1244
ansible and openshift-ansible security and bug fix update
Released 2017-05-17 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat OpenShift Container Platform 3.2 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.2.56-1.git.0.b844ab7.el7, openshift-ansible-3.2.56-1.git.0.b844ab7.el7 +5
- Red Hat OpenShift Container Platform 3.3 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.3.82-1.git.0.af0c922.el7, openshift-ansible-3.3.82-1.git.0.af0c922.el7 +6
- Red Hat OpenShift Container Platform 3.4 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.4.89-1.git.0.ac29ce8.el7, openshift-ansible-3.4.89-1.git.0.ac29ce8.el7 +6
- Red Hat OpenShift Container Platform 3.5 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.5.71-1.git.0.128c2db.el7, openshift-ansible-3.5.71-1.git.0.128c2db.el7 +6
Fixes 2 records
Priority MEDIUM 50
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04743 · Published 2018-07-19 · Partial fix · 2.3.1.0, 2.1.6.0 +1 CWE-20
Priority MEDIUM 40
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems.
CVSS 3.0HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.03005 · Published 2018-06-22 · Fixed in 2.2.3.0 CWE-20