Improper input validation in [UNKNOWN] ansible
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | ansible | ansible 2.3 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.2.3.0 | 2.2.3.0 | Patch available | GHSA-3m8p-xpm6-8ww3 |
- ansible Vendor[UNKNOWN] Affected ansible 2.3 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.2.3.0 Fixed in 2.2.3.0 Patch available GHSA-3m8p-xpm6-8ww3
Remediation
- Fix · GHSA-3m8p-xpm6-8ww3 ansible (PyPI) Fixed in 2.2.3.0 Advisory →
Red Hat 6 advisories
- RHSA-2017:1685 Released 2017-07-06 · Red Hat rating Importantansible security, bug fix, and enhancement update
- Red Hat Virtualization Manager 4.1 ansible-2.3.0.0-4.el7, ansible-doc-2.3.0.0-4.el7
- RHSA-2017:1599 Released 2017-06-28 · Red Hat rating Importantansible security update
- Red Hat OpenStack Platform 10.0 ansible-2.2.3.0-1.el7
- RHSA-2017:1499 Released 2017-06-19 · Red Hat rating Importantansible security update
- Red Hat Storage Console Installer 2 ansible-2.2.3.0-1.el7
Show 3 more Red Hat advisories
- RHSA-2017:1476 Released 2017-06-15 · Red Hat rating Importantansible security update
- Red Hat OpenStack Platform 11.0 ansible-2.2.3.0-1.el7
- RHSA-2017:1334 Released 2017-05-25 · Red Hat rating Importantansible security update
- Red Hat Gluster Storage Server 3.2 on RHEL-7 ansible-2.2.3.0-1.el7
- RHSA-2017:1244 Released 2017-05-17 · Red Hat rating Importantansible and openshift-ansible security and bug fix update
- Red Hat OpenShift Container Platform 3.2 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.2.56-1.git.0.b844ab7.el7, openshift-ansible-3.2.56-1.git.0.b844ab7.el7 +5
- Red Hat OpenShift Container Platform 3.3 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.3.82-1.git.0.af0c922.el7, openshift-ansible-3.3.82-1.git.0.af0c922.el7 +6
- Red Hat OpenShift Container Platform 3.4 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.4.89-1.git.0.ac29ce8.el7, openshift-ansible-3.4.89-1.git.0.ac29ce8.el7 +6
- Red Hat OpenShift Container Platform 3.5 ansible-2.2.3.0-1.el7, atomic-openshift-utils-3.5.71-1.git.0.128c2db.el7, openshift-ansible-3.5.71-1.git.0.128c2db.el7 +6
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Gluster Storage Server 3.2 on RHEL-7 | Fixed | RHSA-2017:1334 |
| Red Hat OpenShift Container Platform 3.2 | Fixed | RHSA-2017:1244 |
| Red Hat OpenShift Container Platform 3.3 | Fixed | RHSA-2017:1244 |
| Red Hat OpenShift Container Platform 3.4 | Fixed | RHSA-2017:1244 |
| Red Hat OpenShift Container Platform 3.5 | Fixed | RHSA-2017:1244 |
| Red Hat OpenStack Platform 10.0 | Fixed | RHSA-2017:1599 |
| Red Hat OpenStack Platform 11.0 | Fixed | RHSA-2017:1476 |
| Red Hat Storage Console Installer 2 | Fixed | RHSA-2017:1499 |
| Red Hat Virtualization Manager 4.1 | Fixed | RHSA-2017:1685 |
Not affected: 2 products
- Red Hat OpenStack Platform 12 (Pike)
- Red Hat Quickstart Cloud Installer 1
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7466
- 2026-10-03 Alias added: GHSA-3m8p-xpm6-8ww3
References
Advisory 8
Other 6
- https://github.com/ansible/ansible/issues/24186
- https://github.com/ansible/ansible/commit/0d418789a298561fded9bce977d34babc9097079
- https://github.com/ansible/ansible/commit/7ff9fa52cfcef2065f0db80d85dd94b9b754839c
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-40.yaml
- https://web.archive.org/web/20170701161323/http://www.securityfocus.com/bid/97595
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-7466 · CVE Program
- CVE-2017-7466 · NVD
- FIRST EPSS
- GHSA-3m8p-xpm6-8ww3 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7466 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences