Red Hat Security AdvisoryRHSA-2020:1542
Ansible security and bug fix update (2.9.7)
Released 2020-04-22 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.7-1.el7ae, ansible-test-2.9.7-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.7-1.el8ae, ansible-test-2.9.7-1.el8ae
Fixes 10 records
Priority LOW 34
A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled,…
CVSS 3.1HIGH 7.9· Local · Low privileges · User interaction · EPSS 0.00331 · Published 2020-03-24 · Partial fix · 2.7.17, 2.8.11 +1 CWE-362
Priority LOW 34
A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination…
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00365 · Published 2020-03-09 · Partial fix · 2.8.9, 2.9.6 +1 CWE-22
Priority LOW 25
A flaw was found in Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 whe…
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00361 · Published 2020-05-11 · Partial fix · 2.7.17, 2.8.11 +1 CWE-459
Priority LOW 25
A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all Ansible 2.9.x versions prior to 2.9.7, when managing kubernetes using the k8s mo…
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00506 · Published 2020-03-16 · Partial fix · 2.7.18, 2.8.12 +1 CWE-200
Priority LOW 23
An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install.
CVSS 3.1MEDIUM 5.2· Local · Low privileges · No interaction · EPSS 0.00303 · Published 2020-04-30 · Fixed in 2.9.7 CWE-22
Priority LOW 23
A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3…
CVSS 3.1MEDIUM 5.0· Local · Low privileges · User interaction · EPSS 0.0039 · Published 2020-05-12 · Partial fix · 2.8.11, 2.9.7 +1 CWE-200
Priority LOW 23
A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user.
CVSS 3.1MEDIUM 5.0· Local · Low privileges · User interaction · EPSS 0.004 · Published 2020-03-11 · Partial fix · 2.7.17, 2.8.11 +1 CWE-377
Priority LOW 22
A flaw was found in Ansible Engine when using Ansible Vault for editing encrypted files.
CVSS 3.1MEDIUM 4.7· Local · Low privileges · No interaction · EPSS 0.0036 · Published 2020-03-16 · Partial fix · 2.7.17, 2.8.11 +1 CWE-377
Priority LOW 22
A flaw was found in the Ansible Engine when the fetch module is used.
CVSS 3.1MEDIUM 4.6· Local · High privileges · No interaction · EPSS 0.00468 · Published 2020-03-16 · Partial fix · 2.7.18, 2.8.12 +1 CWE-22
Priority LOW 18
A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the s…
CVSS 3.1LOW 3.9· Local · Low privileges · User interaction · EPSS 0.00358 · Published 2020-03-12 · Partial fix · 2.7.17, 2.8.11 +1 CWE-200