Information disclosure in Red Hat ansible
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 9 fixed, 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | ansible | ansible-engine versions 2.7.x before 2.7.17; ansible-engine versions 2.8.x before 2.8.11; ansible-engine versions 2.9.x before 2.9.7; Ansible Tower <= 3.4.5; Ansible Tower <= 3.5.5; Ansible Tower <= 3.6.3 | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.8.0a1 to before 2.8.11 | 2.8.11 | Patch available | GHSA-j2h6-73x8-22c4 |
| — | ansible (PyPI) | 2.9.0a1 to before 2.9.7 | 2.9.7 | Patch available | GHSA-j2h6-73x8-22c4 |
| — | ansible (PyPI) | 2.7.0a1 to before 2.7.17 | 2.7.17 | Patch available | GHSA-j2h6-73x8-22c4 |
- ansible VendorRed Hat Affected ansible-engine versions 2.7.x before 2.7.17; ansible-engine versions 2.8.x before 2.8.11; ansible-engine versions 2.9.x before 2.9.7; Ansible Tower <= 3.4.5; Ansible Tower <= 3.5.5; Ansible Tower <= 3.6.3 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.8.0a1 to before 2.8.11 Fixed in 2.8.11 Patch available GHSA-j2h6-73x8-22c4
- ansible (PyPI) Vendor— Affected 2.9.0a1 to before 2.9.7 Fixed in 2.9.7 Patch available GHSA-j2h6-73x8-22c4
- ansible (PyPI) Vendor— Affected 2.7.0a1 to before 2.7.17 Fixed in 2.7.17 Patch available GHSA-j2h6-73x8-22c4
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* | 2.7.0 to before 2.7.17; 2.8.0 to before 2.8.11; 2.9.0 to before 2.9.7 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:* | 3.4.0 – 3.4.5; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.17; 2.8.0 to before 2.8.11; 2.9.0 to before 2.9.7 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:* Versions 3.4.0 – 3.4.5; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-j2h6-73x8-22c4 ansible (PyPI) Fixed in 2.8.11 Advisory →
- Fix · GHSA-j2h6-73x8-22c4 ansible (PyPI) Fixed in 2.9.7 Advisory →
- Fix · GHSA-j2h6-73x8-22c4 ansible (PyPI) Fixed in 2.7.17 Advisory →
Red Hat 4 advisories
- RHSA-2020:1543 Released 2020-04-22 · Red Hat rating ImportantAnsible security and bug fix update (2.8.11)
- Red Hat Ansible Engine 2.8 for RHEL 7 Server ansible-2.8.11-1.el7ae
- Red Hat Ansible Engine 2.8 for RHEL 8 ansible-2.8.11-1.el8ae
- RHSA-2020:1544 Released 2020-04-22 · Red Hat rating ImportantAnsible security and bug fix update (2.7.17)
- Red Hat Ansible Engine 2.7 for RHEL 7 Server ansible-2.7.17-1.el7ae
- RHSA-2020:1542 Released 2020-04-22 · Red Hat rating ImportantAnsible security and bug fix update (2.9.7)
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.7-1.el7ae, ansible-test-2.9.7-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.7-1.el8ae, ansible-test-2.9.7-1.el8ae
Show 1 more Red Hat advisories
- RHSA-2020:1541 Released 2020-04-22 · Red Hat rating ImportantAnsible security and bug fix update (2.9.7)
- Red Hat Ansible Engine 2.9 for RHEL 7 Server ansible-2.9.7-1.el7ae, ansible-test-2.9.7-1.el7ae
- Red Hat Ansible Engine 2.9 for RHEL 8 ansible-2.9.7-1.el8ae, ansible-test-2.9.7-1.el8ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 2 | Affected | No fix planned: Out of support scope |
| Red Hat Ceph Storage 3 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Will not fix |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2020:1542 |
| Red Hat Ansible Engine 2 for RHEL 8 | Fixed | RHSA-2020:1542 |
| Red Hat Ansible Engine 2.7 for RHEL 7 Server | Fixed | RHSA-2020:1544 |
| Red Hat Ansible Engine 2.8 for RHEL 7 Server | Fixed | RHSA-2020:1543 |
| Red Hat Ansible Engine 2.8 for RHEL 8 | Fixed | RHSA-2020:1543 |
| Red Hat Ansible Engine 2.9 for RHEL 7 Server | Fixed | RHSA-2020:1541 |
| Red Hat Ansible Engine 2.9 for RHEL 8 | Fixed | RHSA-2020:1541 |
| Red Hat Ansible Tower 3.4 for RHEL 7 Server | Fixed | — |
| Red Hat Ansible Tower 3.5 for RHEL 7 Server | Fixed | — |
Not affected: 1 product
- CloudForms Management Engine 5
Timeline
- 2026-10-02 Threatist record created from CVE-2020-1746
- 2026-10-03 Alias added: GHSA-j2h6-73x8-22c4
References
Advisory 4
Other 5
- https://github.com/ansible/ansible/commit/d41e38435b1a9e300d8011ac28f16a5add2db119
- https://github.com/ansible/ansible/commit/e6199d768c1c18a4e750ec78d4ded088629baa3f
- https://github.com/ansible/ansible/commit/edd1e1723cc937ec9251adf38c1199a00b0bf6d4
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-13.yaml
More Red Hat Ansible Engine vulnerabilities
- TI-2018-05593 transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before… CVSS 3.1CRITICAL 9.8
- TI-2017-05127 Improper input validation in [UNKNOWN] ansible CVSS 3.1CRITICAL 9.8
- TI-2021-03523 Information disclosure in ansible CVSS 3.1HIGH 7.5
- TI-2019-11051 Sensitive information in log files in Red Hat Ansible CVSS 3.1HIGH 7.8
- TI-2018-07689 Untrusted search path in [UNKNOWN] ansible CVSS 3.1HIGH 7.8
- TI-2018-07688 Untrusted search path in [UNKNOWN] ansible CVSS 3.0HIGH 7.8
Sources
- CVE-2020-1746 · CVE Program
- CVE-2020-1746 · NVD
- FIRST EPSS
- GHSA-j2h6-73x8-22c4 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-1746 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences