Read the docs
TI-2020-01683 Aliases CVE-2020-1739GHSA-923p-fr2c-g5m2

Information disclosure in Red Hat Ansible

Priority LOW 18CWE-200Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 9 fixed, 5 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.

Summary

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Why it matters now

EPSS 0.00358 29th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.7.17, 2.8.11, 2.9.7Red Hat: 4 advisoriesRed Hat: 9 fixed, 5 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red HatAnsibleup to 2.7.16; up to 2.8.8; up to 2.9.5—No fix listedCNA
—ansible (PyPI)before 2.7.172.7.17Patch availableGHSA-923p-fr2c-g5m2
—ansible (PyPI)2.8.0a1 to before 2.8.112.8.11Patch availableGHSA-923p-fr2c-g5m2
—ansible (PyPI)2.9.0a1 to before 2.9.72.9.7Patch availableGHSA-923p-fr2c-g5m2
  • Ansible VendorRed Hat Affected up to 2.7.16; up to 2.8.8; up to 2.9.5 Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected before 2.7.17 Fixed in 2.7.17 Patch available GHSA-923p-fr2c-g5m2
  • ansible (PyPI) Vendor— Affected 2.8.0a1 to before 2.8.11 Fixed in 2.8.11 Patch available GHSA-923p-fr2c-g5m2
  • ansible (PyPI) Vendor— Affected 2.9.0a1 to before 2.9.7 Fixed in 2.9.7 Patch available GHSA-923p-fr2c-g5m2

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*up to 2.7.16; 2.8.0 – 2.8.8; 2.9.0 – 2.9.5VulnerableRed Hat
cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:*up to 3.3.4; 3.4.0 – 3.4.5; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3VulnerableRed Hat
cpe:2.3:a:redhat:cloudforms_management_engine:5.0:*:*:*:*:*:*:*5.0VulnerableRed Hat
cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:*13VulnerableRed Hat
cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*30VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions up to 2.7.16; 2.8.0 – 2.8.8; 2.9.0 – 2.9.5 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:ansible_tower:*:*:*:*:*:*:*:* Versions up to 3.3.4; 3.4.0 – 3.4.5; 3.5.0 – 3.5.5; 3.6.0 – 3.6.3 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:cloudforms_management_engine:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
  • cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Red Hat
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-923p-fr2c-g5m2 ansible (PyPI) Fixed in 2.7.17 Advisory →
  • Fix · GHSA-923p-fr2c-g5m2 ansible (PyPI) Fixed in 2.8.11 Advisory →
  • Fix · GHSA-923p-fr2c-g5m2 ansible (PyPI) Fixed in 2.9.7 Advisory →

Red Hat 4 advisories

  • RHSA-2020:1543 Released 2020-04-22 · Red Hat rating Important
    Ansible security and bug fix update (2.8.11)
    • Red Hat Ansible Engine 2.8 for RHEL 7 Server ansible-2.8.11-1.el7ae
    • Red Hat Ansible Engine 2.8 for RHEL 8 ansible-2.8.11-1.el8ae
  • RHSA-2020:1544 Released 2020-04-22 · Red Hat rating Important
    Ansible security and bug fix update (2.7.17)
    • Red Hat Ansible Engine 2.7 for RHEL 7 Server ansible-2.7.17-1.el7ae
  • RHSA-2020:1542 Released 2020-04-22 · Red Hat rating Important
    Ansible security and bug fix update (2.9.7)
    • Red Hat Ansible Engine 2 for RHEL 7 ansible-2.9.7-1.el7ae, ansible-test-2.9.7-1.el7ae
    • Red Hat Ansible Engine 2 for RHEL 8 ansible-2.9.7-1.el8ae, ansible-test-2.9.7-1.el8ae
Show 1 more Red Hat advisories
  • RHSA-2020:1541 Released 2020-04-22 · Red Hat rating Important
    Ansible security and bug fix update (2.9.7)
    • Red Hat Ansible Engine 2.9 for RHEL 7 Server ansible-2.9.7-1.el7ae, ansible-test-2.9.7-1.el7ae
    • Red Hat Ansible Engine 2.9 for RHEL 8 ansible-2.9.7-1.el8ae, ansible-test-2.9.7-1.el8ae

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Red Hat Ansible — FEDORA-2020-a3f12bcff4

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

  • Advisory ·

    Red Hat Ansible — FEDORA-2020-0cab7041f7

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

Show 1 more group
  • Advisory ·

    Red Hat Ansible — FEDORA-2020-87f5e1e829

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ceph Storage 2AffectedNo fix planned: Out of support scope
Red Hat Ceph Storage 3AffectedNo fix yet: Fix deferred
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Will not fix
Red Hat Storage 3AffectedNo fix planned: Will not fix
Red Hat Ansible Engine 2 for RHEL 7Fixed RHSA-2020:1542
Red Hat Ansible Engine 2 for RHEL 8Fixed RHSA-2020:1542
Red Hat Ansible Engine 2.7 for RHEL 7 ServerFixed RHSA-2020:1544
Red Hat Ansible Engine 2.8 for RHEL 7 ServerFixed RHSA-2020:1543
Red Hat Ansible Engine 2.8 for RHEL 8Fixed RHSA-2020:1543
Red Hat Ansible Engine 2.9 for RHEL 7 ServerFixed RHSA-2020:1541
Red Hat Ansible Engine 2.9 for RHEL 8Fixed RHSA-2020:1541
Red Hat Ansible Tower 3.4 for RHEL 7 ServerFixed—
Red Hat Ansible Tower 3.5 for RHEL 7 ServerFixed—
Not affected: 1 product
  • CloudForms Management Engine 5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-1739
  2. 2026-10-03 Alias added: GHSA-923p-fr2c-g5m2

References

  • TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
  • TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
  • TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
See all 44 →

Sources