Read the docs
Red Hat Security Advisory

RHSA-2026:59635

Red Hat Hardened Images RPMs bug fix and enhancement update

Released 2026-08-25 · Red Hat rating Important · View on Red Hat →

Fixed in

Fixes 27 records

Priority MEDIUM 51

Issue summary: OpenSSL CMP response validation passed an unexpected response sender distinguished name directly as the format string to `ERR_raise_data()`.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.01159 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +2 CWE-134
Priority MEDIUM 47

Issue summary: ChaCha20-Poly1305 and AES-OCB decryption with an empty ciphertext can report success without verifying the supplied authentication tag when the operation is finalized by calling the EVP_Cipher() function.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00254 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +3 CWE-354
Priority MEDIUM 47

Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a use-after-free during PKCS#7 signature verification.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04002 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-416
Priority MEDIUM 47

Issue Summary: Cryptographic Message Services (CMS) processing fails to perform sufficient input validation on the cipher and tag length fields of AuthEnvelopedData containers, leading to various potential compromises.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.01057 Published 2026-06-09 Fixed in 4.0.1, 3.6.3 +3 CWE-354
Priority MEDIUM 42

Issue summary: OpenSSL CMP password based protection verification only checks whether the protectionAlg parameter was not NULL and not its ASN.1 type, before treating it as a PBMParameter.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01602 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +3 CWE-476
Priority MEDIUM 42

Issue summary: QUIC server may double free QRX (QUIC record layer RX) object when channel creation fails for initial packet.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01697 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +1 CWE-415
TI-2026-45026 CVE-2026-63072 · GHSA-wp5f-6q39-q2f4

Heap Buffer Overflow in CMS Key Unwrapping

Priority MEDIUM 41

Issue summary: OpenSSL CMS decryption sizes the key-unwrap output buffer based on querying the unwrapped key size, but the AES-WRAP-PAD unwrap primitive can write and cleanse more bytes than that query reports, causing a…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00916 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +4 CWE-787
Priority MEDIUM 41

Issue summary: Receiving a QUIC initial packet with an invalid token may trigger a NULL pointer dereference in the OpenSSL QUIC server with address validation disabled.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01165 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +1 CWE-476
Priority MEDIUM 41

Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATH_CHALLENGE frames.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01049 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-1325
Priority MEDIUM 41

Issue summary: In a server or client configuration with RFC7250 Raw Public Keys (RPKs) enabled, and only the private key (with no associated certificate) configured locally, a NULL pointer dereference may occur when the…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01167 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +2 CWE-476
Priority MEDIUM 40

Issue summary: When OpenSSL processes QUIC traffic from a peer that repeatedly sends ack-eliciting packets while not acknowledging ACK-only responses, the QUIC stack can retain ACK-only packet metadata for the lifetime o…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0057 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +2 CWE-770
Priority MEDIUM 40

Issue summary: Receiving a DTLS record for a future epoch while a handshake is in progress causes OpenSSL to buffer far more memory than the record itself requires.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00622 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +5 CWE-405
TI-2026-33224 CVE-2026-45445 · GHSA-v446-xwfm-x7mr

AES-OCB IV Ignored on EVP_Cipher() Path

Priority MEDIUM 40

Issue summary: When an application drives an AES-OCB context through the public EVP_Cipher() one-shot interface, the application-supplied initialisation vector (IV) is silently discarded.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00704 Published 2026-06-09 Fixed in 4.0.1, 3.6.3 +3 CWE-325
Priority MEDIUM 40

Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes attacker-supplied CMS data, an attacker-chosen stream-mode KEK cipher can trigger a heap out-of-bounds read in kek_unwrap_key().

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00707 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-125
Priority LOW 39

Issue summary: When a partial-chain certificate verification is enabled together with OCSP response checking for the whole chain, a NULL dereference will happen if the verified chain does not have a self-signed trusted a…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00508 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 CWE-476
Priority LOW 39

Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1_mbstring_ncopy() can lead to a heap buffer overflow.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.00804 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-787
Priority LOW 35

Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buffer over-read on 64-bit Unix and Unix-like platforms.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01025 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-125
Priority LOW 33

Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client application.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.00557 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +3 CWE-476
Priority LOW 33

Issue Summary: The PKCS#12 file processing fails to perform sufficient input validation for files that use Password-Based Message Authentication Code 1 (PBMAC1) integrity mechanism allowing a certificate and private key…

CVSS 3.1HIGH 7.4 Network No auth No interaction EPSS 0.00376 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-354
Priority LOW 29

Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.0106 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-476
TI-2026-45028 CVE-2026-63074 · GHSA-2q27-mpm9-44m4

CMP Indefinite Cache Growth of ExtraCerts

Priority LOW 27

Issue summary: The OpenSSL Certificate Management Protocol (CMP) caches additional certificates (extraCerts) sent in a CMP message, but never expunges them (for instance if they are invalid).

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.00588 Published 2026-08-25 Partial fix · 4.0.2, 3.6.4 +3 CWE-770
Priority LOW 27

Issue summary: When the X509_VERIFY_PARAM_set1_email is called by an application to validate a crafted e-mail address, such as during S/MIME message validation, an out of bounds read can happen.

CVSS 3.1MEDIUM 6.2 Local No auth No interaction EPSS 0.00218 Published 2026-06-09 Partial fix · 4.0.1 CWE-125
Priority LOW 25

Issue Summary: An error in the callback used to verify the certificate provided in a Root CA key update Certificate Management Protocol (CMP) message response rendered the certificate validation ineffectual, which could…

CVSS 3.1MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00544 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-295
Priority LOW 25

Issue summary: A malicious server can exploit TLS OCSP stapling by delivering a crafted response through the status_request extension, triggering a double-free in the client's certificate verification path.

CVSS 3.1MEDIUM 5.0 Network Low privileges No interaction EPSS 0.00302 Published 2026-06-09 Fixed in 4.0.1, 3.6.3 CWE-415
Priority LOW 22

Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452) mishandle the authentication of AAD (Additional Authenticated Data) with an empty ciphertext allowing a forgery of such messages.

CVSS 3.1MEDIUM 4.8 Network No auth No interaction EPSS 0.00439 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +3 CWE-325
Priority LOW 19

Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to Bleichenbacher-style attack when an attacker is able to provide the CMS or S/MIME messages and observe the error code and/or decryption output.

CVSS 3.1LOW 3.7 Network No auth No interaction EPSS 0.00801 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-514
Priority LOW 18

Issue summary: When EVP_PKEY_derive_set_peer() is called with a DHX (X9.42) peer key, the peer key is not properly checked for the subgroup membership.

CVSS 3.1LOW 3.7 Network No auth No interaction EPSS 0.00503 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +3 CWE-325