Read the docs

Apache

Records4054All Threatist records
Exploited (KEV)47In CISA KEV
CVSS critical776CVSS 9.0–10.0
CVSS high1543CVSS 7.0–8.9

Exploited now

Apache records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

47 records in Subversion · all components

Priority HIGH 71

Integer overflow in the read_string function in libsvn_ra_svn/marshal.c in Apache Subversion 1.9.x before 1.9.3 allows remote attackers to execute arbitrary code via an svn:// protocol string, which triggers a heap-based…

CVSS 3.0HIGH 8.6 Network No auth No interaction EPSS 0.57037 Published 2016-01-08 No fix listed CWE-119
Priority MEDIUM 60

Subversion's mod_authz_svn module will crash if the server is using in-repository authz rules with the AuthzSVNReposRelativeAccessFile option and a client sends a request for a non-existing repository URL.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.40075 Published 2021-03-17 Fixed in mod_authz_svn 1.10.7, 1.14.1 CWE-476
Priority MEDIUM 60

A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha3 to run an arbitrary shell command.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.18892 Published 2017-08-11 Partial fix CWE-20
Priority MEDIUM 57

Integer overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before 1.8.15, and 1.9.x before 1.9.3 allows remote authenticated users to cause a denial of service (subversion server crash or memory consumpt…

CVSS 3.0HIGH 7.6 Network Low privileges No interaction EPSS 0.30216 Published 2016-04-14 Will not fix CWE-119
Priority MEDIUM 54

The mod_dav_svn Apache HTTPD server module in Subversion 1.7.0 through 1.7.8 allows remote attackers to cause a denial of service (segmentation fault and crash) via a log REPORT request with an invalid limit, which trigg…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.50538 Published 2013-05-02 No fix listed CWE-119
Priority MEDIUM 48

The req_check_access function in the mod_authz_svn module in the httpd server in Apache Subversion before 1.8.16 and 1.9.x before 1.9.4 allows remote authenticated users to cause a denial of service (NULL pointer derefer…

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.20686 Published 2016-05-05 Will not fix
Priority MEDIUM 45

On Windows platforms, a "best fit" character encoding conversion of command line arguments to Subversion's executables (e.g., svn.exe, etc.) may lead to unexpected command line argument interpretation, including argument…

CVSS 3.1HIGH 8.2 Local Low privileges User interaction EPSS 0.00611 Published 2024-10-09 No fix listed CWE-78
Priority MEDIUM 43

libsvn_fs_fs/fs_fs.c in Apache Subversion 1.8.x before 1.8.2 might allow remote authenticated users with commit access to corrupt FSFS repositories and cause a denial of service or obtain sensitive information by editing…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.02824 Published 2017-10-30 No fix listed CWE-284
Priority MEDIUM 40

The canonicalize_username function in svnserve/cyrus_auth.c in Apache Subversion before 1.8.16 and 1.9.x before 1.9.4, when Cyrus SASL authentication is used, allows remote attackers to authenticate and bypass intended a…

CVSS 3.0MEDIUM 6.8 Network Low privileges No interaction EPSS 0.06814 Published 2016-05-05 Will not fix CWE-284
Priority LOW 39

In Apache Subversion versions up to and including 1.9.10, 1.10.4, 1.12.0, Subversion's svnserve server process may exit when a client sends certain sequences of protocol commands.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.0344 Published 2019-09-26 Fixed CWE-476
Priority LOW 38

Apache Subversion's mod_dontdothat module and HTTP clients 1.4.0 through 1.8.16, and 1.9.0 through 1.9.4 are vulnerable to a denial-of-service attack caused by exponential XML entity expansion.

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.0638 Published 2017-10-16 Will not fix CWE-400
Priority LOW 37

The (1) mod_dav_svn and (2) svnserve servers in Subversion 1.6.0 through 1.7.19 and 1.8.0 through 1.8.11 allow remote attackers to cause a denial of service (assertion failure and abort) via crafted parameter combination…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.12754 Published 2015-04-08 Partial fix CWE-399
Priority LOW 33

In Apache Subversion versions up to and including 1.9.10, 1.10.4, 1.12.0, Subversion's svnserve server process may exit when a well-formed read-only request produces a particular answer.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.02422 Published 2019-09-26 Partial fix CWE-20
Load more
Open these records in search →