Read the docs

blubrry

Records23All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high4CVSS 7.0–8.9

Exploited now

blubrry records in CISA KEV

No blubrry vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

23 records

Priority MEDIUM 60

The PowerPress Podcasting plugin by Blubrry WordPress plugin before 11.9.18 does not sanitise and escape some of its settings when adding a podcast, which could allow author and above users to perform Stored Cross-Site S…

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00273 Published 2025-04-14 Fixed in 11.9.18 CWE-79
Priority MEDIUM 58

The PowerPress Podcasting plugin by Blubrry WordPress plugin before 11.0.12 does not sanitize and escape the media url field in posts, which could allow users with privileges as low as contributor to inject arbitrary web…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00471 Published 2023-10-16 Fixed in 11.0.12
Priority MEDIUM 55

The PowerPress Podcasting plugin by Blubrry WordPress plugin before 11.9.18 does not sanitise and escape some of its settings when adding a podcast, which could allow admin users to perform Stored Cross-Site Scripting at…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 11.9.18 CWE-79
Priority MEDIUM 43

Unrestricted Upload of File with Dangerous Type vulnerability in blubrry PowerPress Podcasting powerpress allows Upload a Web Shell to a Web Server.This issue affects PowerPress Podcasting: from n/a through <= 11.12.5.

CVSS 3.1CRITICAL 9.9 Network Low privileges No interaction EPSS 0.00443 Published 2025-04-24 No fix listed CWE-434
Priority LOW 35

Arbitrary file upload in the PowerPress WordPress plugin, versions before 8.3.8, did not verify some of the uploaded feed images (such as the ones from Podcast Artwork section), allowing high privilege accounts (admin+)…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01647 Published 2021-03-18 Fixed in 8.3.8 CWE-434
Priority LOW 29

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in blubrry PowerPress Podcasting powerpress allows DOM-Based XSS.This issue affects PowerPress Podcasting: from n/a throu…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00298 Published 2025-04-09 No fix listed CWE-79
Priority LOW 29

The PowerPress Podcasting plugin by Blubrry plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘media_url’ parameter in all versions up to, and including, 11.9.10 due to insufficient input sanit…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00384 Published 2024-07-12 No fix listed CWE-79
Priority LOW 28

The PowerPress Podcasting plugin by Blubrry plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'embed' Episode Meta Field in all versions up to, and including, 11.16.8 due to insufficient input sanitiz…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00196 Published 2026-06-18 No fix listed CWE-79
Priority LOW 28

The Blubrry PowerPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'powerpress' and 'podcast' shortcodes in versions up to, and including, 11.15.15 due to insufficient input sanitization and…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00213 Published 2026-04-08 No fix listed CWE-79
Priority LOW 28

The PowerPress Podcasting plugin by Blubrry plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'skipto' shortcode in all versions up to, and including, 11.9.18 due to insufficient input sa…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00342 Published 2024-10-11 No fix listed CWE-79
Priority LOW 26

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in blubrry PowerPress Podcasting powerpress allows Stored XSS.This issue affects PowerPress Podcasting: from n/a through…

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00183 Published 2026-03-13 No fix listed CWE-79
Priority LOW 25

The PowerPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in versions up to, and including, 10.0 due to insufficient input sanitization and output escaping on user sup…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00529 Published 2023-06-09 No fix listed CWE-79
Open these records in search →