PowerPress < 8.3.8 - Authenticated Arbitrary File Upload leading to RCE
Priority LOW 35CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
Arbitrary file upload in the PowerPress WordPress plugin, versions before 8.3.8, did not verify some of the uploaded feed images (such as the ones from Podcast Artwork section), allowing high privilege accounts (admin+) being able to upload arbitrary files, such as php, leading to RCE.
Why it matters now
EPSS 0.01647 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PowerPress (Unknown): 8.3.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PowerPress | 8.3.8 to before 8.3.8 | 8.3.8 | Patch available | CNA |
- PowerPress VendorUnknown Affected 8.3.8 to before 8.3.8 Fixed in 8.3.8 Patch available CNA
Remediation
- Fix · CNA PowerPress (Unknown) Fixed in 8.3.8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24123
- 2026-10-03 Alias added: GHSA-7cm9-xr5m-957v
References
More blubrry Powerpress vulnerabilities
- TI-2024-08566 PowerPress Podcasting < 11.9.18 - Author+ XSS via Podcast URL CVSS 3.1MEDIUM 5.9
- TI-2023-04437 PowerPress Podcasting < 11.0.12 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-08563 PowerPress Podcasting < 11.9.18 - Author+ XSS CVSS 3.1MEDIUM 4.8
- TI-2023-21848 WordPress PowerPress Podcasting Plugin <= 11.0.6 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1MEDIUM 6.5
- TI-2015-07787 The Blubrry PowerPress Podcasting plugin 6.0.4 for WordPress has XSS via the tab parameter. CVSS 3.1MEDIUM 5.4
- TI-2023-14590 WordPress PowerPress Podcasting Plugin <= 10.0.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.5
Sources
- CVE-2021-24123 · CVE Program
- CVE-2021-24123 · NVD
- FIRST EPSS
- GHSA-7cm9-xr5m-957v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences