PowerPress Podcasting < 11.0.12 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The PowerPress Podcasting plugin by Blubrry WordPress plugin before 11.0.12 does not sanitize and escape the media url field in posts, which could allow users with privileges as low as contributor to inject arbitrary web scripts that could target a site admin or superadmin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed PowerPress Podcasting plugin by Blubrry (Unknown): 11.0.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PowerPress Podcasting plugin by Blubrry | before 11.0.12 | 11.0.12 | Patch available | CNA |
- PowerPress Podcasting plugin by Blubrry VendorUnknown Affected before 11.0.12 Fixed in 11.0.12 Patch available CNA
Remediation
- Fix · CNA PowerPress Podcasting plugin by Blubrry (Unknown) Fixed in 11.0.12
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4820
- 2026-10-03 Alias added: GHSA-hfr4-7364-jv2q
References
More blubrry Powerpress vulnerabilities
- TI-2024-08566 PowerPress Podcasting < 11.9.18 - Author+ XSS via Podcast URL CVSS 3.1MEDIUM 5.9
- TI-2024-08563 PowerPress Podcasting < 11.9.18 - Author+ XSS CVSS 3.1MEDIUM 4.8
- TI-2021-06415 PowerPress < 8.3.8 - Authenticated Arbitrary File Upload leading to RCE CVSS 3.1HIGH 7.2
- TI-2023-21848 WordPress PowerPress Podcasting Plugin <= 11.0.6 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1MEDIUM 6.5
- TI-2015-07787 The Blubrry PowerPress Podcasting plugin 6.0.4 for WordPress has XSS via the tab parameter. CVSS 3.1MEDIUM 5.4
- TI-2023-14590 WordPress PowerPress Podcasting Plugin <= 10.0.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.5
Sources
- CVE-2023-4820 · CVE Program
- CVE-2023-4820 · NVD
- FIRST EPSS
- GHSA-hfr4-7364-jv2q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences