Priority HIGH 81
In the wp-google-maps plugin before 7.11.18 for WordPress, includes/class.rest-api.php in the REST API does not sanitize field names before a SELECT statement.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.77334 · Published 2019-04-02 · No fix listed CWE-89
Priority MEDIUM 64
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPGMaps WP Go Maps wp-google-maps.This issue affects WP Go Maps: from n/a through <= 9.0.29.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00753 · Published 2024-03-27 · No fix listed CWE-79
Priority MEDIUM 60
The WP Go Maps (formerly WP Google Maps) WordPress plugin before 9.0.28 does not properly protect most of its REST API routes, which attackers can abuse to store malicious HTML/Javascript on the site.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00619 · Published 2024-01-08 · Fixed in 9.0.28 CWE-79
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in WPGMaps WP Go Maps wp-google-maps.This issue affects WP Go Maps: from n/a through <= 9.0.40.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00189 · Published 2025-01-27 · No fix listed CWE-352
Priority LOW 36
The WP Go Maps (formerly WP Google Maps) plugin for WordPress is vulnerable to unauthenticated API key disclosure in versions up to, and including, 9.0.34 due to the plugin adding the API key to several plugin files.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00795 · Published 2024-04-09 · No fix listed CWE-200
Priority LOW 33
The wp-google-maps plugin before 7.10.43 for WordPress has XSS via the wp-admin/admin.php PATH_INFO.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.03137 · Published 2019-03-21 · No fix listed CWE-79
Priority LOW 30
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WP Go Maps (formerly WP Google Maps) plugin <= 9.0.15 versions.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00754 · Published 2023-03-14 · No fix listed CWE-22
Priority LOW 29
The WP Go Maps (formerly WP Google Maps) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Custom JS option in versions up to, and including, 9.0.38.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00367 · Published 2024-06-14 · No fix listed CWE-79
Priority LOW 29
The WP Google Maps WordPress plugin before 8.1.12 did not sanitise, validate of escape the Map Name when output in the Map List of the admin dashboard, leading to an authenticated Stored Cross-Site Scripting issue
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.02467 · Published 2021-06-21 · Fixed in 8.1.12 CWE-79
Priority LOW 28
The WP Go Maps (formerly WP Google Maps) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpgmza shortcode in all versions up to, and including, 9.0.36 due to insufficient input sanitiza…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00322 · Published 2024-05-24 · No fix listed CWE-79
Priority LOW 28
The WP Go Maps (formerly WP Google Maps) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wpgmza' shortcode in all versions up to, and including, 9.0.32 due to insufficient input saniti…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.0032 · Published 2024-03-13 · No fix listed CWE-79
Priority LOW 27
The WP Google Maps plugin before 7.11.35 for WordPress allows XSS via the wp-admin/ rectangle_name or rectangle_opacity parameter.
CVSS 3.0MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01063 · Published 2019-08-09 · No fix listed CWE-79
Priority LOW 26
Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities in WordPress WP Google Maps Pro premium plugin (versions <= 8.1.11).
CVSS 3.1MEDIUM 5.5· Network · High privileges · No interaction · EPSS 0.00557 · Published 2021-09-09 · No fix listed CWE-79
Priority LOW 26
Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities in WordPress WP Google Maps plugin (versions <= 8.1.12).
CVSS 3.1MEDIUM 5.5· Network · High privileges · No interaction · EPSS 0.00585 · Published 2021-09-09 · No fix listed CWE-79
Priority LOW 25
Multiple cross-site scripting (XSS) vulnerabilities in the WP Google Maps plugin before 6.0.27 for WordPress allow remote attackers to inject arbitrary web script or HTML via the poly_id parameter in an (1) edit_poly, (2…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.02461 · Published 2014-10-22 · No fix listed CWE-79
Priority LOW 22
The WP Go Maps for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 9.0.32 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00342 · Published 2024-03-13 · No fix listed CWE-79