WP Go Maps < 9.0.28 - Unauthenticated Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Go Maps (formerly WP Google Maps) WordPress plugin before 9.0.28 does not properly protect most of its REST API routes, which attackers can abuse to store malicious HTML/Javascript on the site.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00619 49th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed WP Go Maps (formerly WP Google Maps) (Unknown): 9.0.28
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Go Maps (formerly WP Google Maps) | before 9.0.28 | 9.0.28 | Patch available | CNA |
- WP Go Maps (formerly WP Google Maps) VendorUnknown Affected before 9.0.28 Fixed in 9.0.28 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codecabin:wp_go_maps:*:*:*:*:basic:wordpress:*:* | before 9.0.28 | Vulnerable | Code Cabin Inc |
- cpe:2.3:a:codecabin:wp_go_maps:*:*:*:*:basic:wordpress:*:* Versions before 9.0.28 Vulnerable ·Code Cabin Inc
Remediation
- Fix · CNA WP Go Maps (formerly WP Google Maps) (Unknown) Fixed in 9.0.28
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6627
- 2026-10-03 Alias added: GHSA-877p-v8mm-jqg9
References
More Code Cabin Inc Wp Go Maps vulnerabilities
- TI-2019-07981 In the wp-google-maps plugin before 7.11.18 for WordPress, includes/class.rest-api.php in… CVSS 3.1CRITICAL 9.8
- TI-2024-19698 WordPress WP Go Maps plugin <= 9.0.29 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2025-18459 WordPress WP Google Maps plugin <= 9.0.40 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2023-06192 WP Go Maps (formerly WP Google Maps) <= 9.0.34 - Information Exposure to Potential Denial of Service CVSS 3.1MEDIUM 6.5
- TI-2019-07284 The wp-google-maps plugin before 7.10.43 for WordPress has XSS via the wp-admin/admin.php PATH_INFO. CVSS 3.1MEDIUM 6.1
- TI-2022-23633 WordPress WP Google Maps Plugin <= 9.0.15 is vulnerable to Path Traversal CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-6627 · CVE Program
- CVE-2023-6627 · NVD
- FIRST EPSS
- GHSA-877p-v8mm-jqg9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences