Priority MEDIUM 54
Blocksy Companion Pro plugin for WordPress before 2.1.47 contains an unauthenticated arbitrary file upload vulnerability that allows attackers to upload executable files by bypassing extension validation in the save_atta…
CVSS 4.0CRITICAL 9.2· Network · No auth · No interaction · EPSS 0.03572 · Published 2026-07-08 · Fixed in 2.1.47 CWE-434
Priority MEDIUM 53
The Blocksy Companion WordPress plugin before 1.8.82 does not ensure that posts to be accessed via a shortcode are already public and can be viewed, allowing any authenticated users, such as subscriber to access draft po…
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.0055 · Published 2023-05-02 · Fixed in 1.8.82 CWE-639
Priority MEDIUM 51
The Blocksy Companion plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 2.1.46 via the save_attachments function.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01067 · Published 2026-07-09 · No fix listed CWE-434
Priority MEDIUM 50
Unauthenticated Remote Code Execution (RCE) in Blocksy Companion Pro <= 2.1.46 versions.
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.0086 · Published 2026-07-02 · No fix listed CWE-94
Priority MEDIUM 47
The Blocksy Companion plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.1.58 This is due to the implement_user_registration() AJAX handler explicitly disabling Dokan's vendor-…
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.00302 · Published 2026-10-10 · No fix listed CWE-269
Priority MEDIUM 46
Unauthenticated SQL Injection in Blocksy Companion Pro < 2.1.29 versions.
CVSS 3.1CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.00372 · Published 2026-06-17 · Fixed in 2.1.29 CWE-89
Priority MEDIUM 44
Contributor Remote Code Execution (RCE) in Blocksy Companion Pro <= 2.1.37 versions.
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.00541 · Published 2026-06-17 · No fix listed CWE-94
Priority MEDIUM 42
The Blocksy theme for WordPress is vulnerable to PHP Object Injection leading to Remote Code Execution via the 'blocksy_meta' REST API field and the V200 database migration in versions up to and including 2.1.35.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01121 · Published 2026-06-09 · No fix listed CWE-502
Priority MEDIUM 41
The Blocksy Companion plugin for WordPress is vulnerable to authenticated arbitrary file upload in all versions up to, and including, 2.1.19.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00735 · Published 2025-11-11 · No fix listed CWE-434
Priority MEDIUM 40
Contributor Remote Code Execution (RCE) in Blocksy Companion Pro <= 2.1.45 versions.
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00582 · Published 2026-06-26 · No fix listed CWE-94
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in creativethemeshq Blocksy blocksy allows Cross Site Request Forgery.This issue affects Blocksy: from n/a through <= 2.0.22.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00192 · Published 2025-01-02 · No fix listed CWE-352
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in CreativeThemes Blocksy Companion.This issue affects Blocksy Companion: from n/a through 2.0.28.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00208 · Published 2024-04-11 · No fix listed CWE-352
Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in creativethemeshq Blocksy blocksy.This issue affects Blocksy: from n/a through <= 2.0.22.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00228 · Published 2024-04-15 · No fix listed CWE-352
Priority LOW 34
Unauthenticated Broken Access Control in Blocksy Companion <= 2.1.55 versions.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00203 · Published 2026-09-30 · No fix listed CWE-862
Priority LOW 30
Unauthenticated Insecure Direct Object References (IDOR) in Blocksy Companion Pro <= 2.1.46 versions.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00313 · Published 2026-06-26 · No fix listed CWE-639
Priority LOW 29
The Blocksy Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'tagName' Block Attribute (blocksy/dynamic-data) in all versions up to, and including, 2.1.51 due to insufficient input sanitiza…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00419 · Published 2026-09-01 · No fix listed CWE-79
Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in creativethemeshq Blocksy blocksy.This issue affects Blocksy: from n/a through <= 2.0.33.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.0032 · Published 2024-04-25 · No fix listed CWE-79
Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in creativethemeshq Blocksy blocksy.This issue affects Blocksy: from n/a through <= 2.0.19.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.0032 · Published 2024-02-08 · No fix listed CWE-79
Priority LOW 29
The Blocksy Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG uploads in versions up to, and including, 2.0.45 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00429 · Published 2024-05-11 · No fix listed CWE-79
Priority LOW 29
The Blocksy theme for WordPress is vulnerable to Stored Cross-Site Scripting via the className parameter in the About Me block in all versions up to, and including, 2.0.39 due to insufficient input sanitization and outpu…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00423 · Published 2024-05-02 · No fix listed CWE-20
Priority LOW 28
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Creative Themes Blocksy Companion blocksy-companion allows Stored XSS.This issue affects Blocksy Companion: from n/a t…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.0017 · Published 2026-10-30 · No fix listed CWE-79
Priority LOW 28
The Blocksy theme for WordPress is vulnerable to Stored Cross-Site Scripting via the `blocksy_meta` metadata fields in all versions up to, and including, 2.1.30 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00222 · Published 2026-03-02 · No fix listed CWE-79
Priority LOW 28
The Blocksy Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'blocksy_newsletter_subscribe' shortcode in all versions up to, and including, 2.1.14 due to insufficient input san…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00201 · Published 2025-10-30 · No fix listed CWE-79
Priority LOW 28
The Blocksy Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's blocksy_newsletter_subscribe shortcode in all versions up to, and including, 2.1.10 due to insufficient input sanit…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00254 · Published 2025-09-17 · No fix listed CWE-79
Priority LOW 28
The Blocksy theme for WordPress is vulnerable to Stored Cross-Site Scripting via the Contact Info Block link parameter in all versions up to, and including, 2.0.77 due to insufficient input sanitization and output escapi…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00256 · Published 2024-12-05 · No fix listed CWE-79
Load more