Blocksy Companion Pro < 2.1.47 Unauthenticated File Upload via save_attachments
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
Blocksy Companion Pro plugin for WordPress before 2.1.47 contains an unauthenticated arbitrary file upload vulnerability that allows attackers to upload executable files by bypassing extension validation in the save_attachments function exposed through the Advanced Reviews feature. Attackers can exploit the Custom Fonts extension's flawed strpos() substring check by uploading double-extension filenames such as shell.woff2.php, causing the validation to pass on the substring match while the web server executes the file as PHP, achieving remote code execution.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| creativethemeshq | Blocksy Companion | up to 2.1.46 | 2.1.47 | Patch available | CNA |
- Blocksy Companion Vendorcreativethemeshq Affected up to 2.1.46 Fixed in 2.1.47 Patch available CNA
Remediation
- Fix · CNA Blocksy Companion (Creative Themes) Fixed in 2.1.47
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58480
- 2026-10-03 Alias added: GHSA-r58f-77hp-phcj
References
Patch 1
Advisory 2
More creativethemeshq vulnerabilities
- TI-2023-01796 Blocksy Companion < 1.8.82 - Subscriber+ Draft Post Access CVSS 3.1MEDIUM 4.3
- TI-2026-12769 Blocksy Companion <= 2.1.46 - Unauthenticated Arbitrary File Upload via 'blc-review-images[]' Parameter CVSS 3.1CRITICAL 9.8
- TI-2026-41450 WordPress Blocksy Companion Pro plugin <= 2.1.46 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 10.0
- TI-2026-70281 Unauthenticated privilege escalation in Blocksy Companion CVSS 3.1CRITICAL 9.1
- TI-2026-28570 WordPress Blocksy Companion Pro plugin < 2.1.29 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
- TI-2026-29451 WordPress Blocksy Companion Pro plugin <= 2.1.37 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-58480 · CVE Program
- CVE-2026-58480 · NVD
- FIRST EPSS
- GHSA-r58f-77hp-phcj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences