Read the docs
TI-2026-28570 Aliases CVE-2026-39596GHSA-r9hh-736v-qcp4

WordPress Blocksy Companion Pro plugin < 2.1.29 - SQL Injection vulnerability

Priority MEDIUM 46CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

Unauthenticated SQL Injection in Blocksy Companion Pro < 2.1.29 versions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00372 31st percentileScored 2026-11-07
Fix Fixed Blocksy Companion Pro (Creative Themes): 2.1.29

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
creativethemeshqBlocksy Companion Probefore 2.1.292.1.29Patch availableCNA
  • Blocksy Companion Pro Vendorcreativethemeshq Affected before 2.1.29 Fixed in 2.1.29 Patch available CNA

Remediation

  • Fix · CNA Blocksy Companion Pro (Creative Themes) Fixed in 2.1.29

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-39596
  2. 2026-10-03 Alias added: GHSA-r9hh-736v-qcp4

References

  • TI-2026-42084 Blocksy Companion Pro < 2.1.47 Unauthenticated File Upload via save_attachments CVSS 4.0CRITICAL 9.2
  • TI-2023-01796 Blocksy Companion < 1.8.82 - Subscriber+ Draft Post Access CVSS 3.1MEDIUM 4.3
  • TI-2026-12769 Blocksy Companion <= 2.1.46 - Unauthenticated Arbitrary File Upload via 'blc-review-images[]' Parameter CVSS 3.1CRITICAL 9.8
  • TI-2026-41450 WordPress Blocksy Companion Pro plugin <= 2.1.46 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2026-70281 Unauthenticated privilege escalation in Blocksy Companion CVSS 3.1CRITICAL 9.1
  • TI-2026-29451 WordPress Blocksy Companion Pro plugin <= 2.1.37 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
See all 35 →

Sources