Priority MEDIUM 51
Incorrect sanitation of the 302 redirect field in HTTP transport method of apt versions 1.4.8 and earlier can lead to content injection by a MITM attacker, potentially leading to remote code execution on the target machi…
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.14555 · Published 2019-01-28 · No fix listed
Priority MEDIUM 50
apt-get in apt before 0.7.21 does not check for the correct error code from gpgv, which causes apt to treat a repository as valid even when it has been signed with a key that has been revoked or expired, which might allo…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.04481 · Published 2009-04-21 · No fix listed
Priority MEDIUM 47
apt 0.7.20 does not check when the date command returns an "invalid date" error, which can prevent apt from loading security updates in time zones for which DST occurs at midnight.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.01856 · Published 2009-04-16 · No fix listed CWE-20
Priority LOW 39
The apt-get download command in APT before 1.0.9 does not properly validate signatures for packages, which allows remote attackers to execute arbitrary code via a crafted package.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.03614 · Published 2014-11-03 · No fix listed CWE-20
Priority LOW 39
APT before 1.0.9, when the Acquire::GzipIndexes option is enabled, does not validate checksums, which allows remote attackers to execute arbitrary code via a crafted package.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.03614 · Published 2014-11-03 · No fix listed CWE-20
Priority LOW 37
The apt package in Debian jessie before 1.0.9.8.4, in Debian unstable before 1.4~beta2, in Ubuntu 14.04 LTS before 1.0.1ubuntu2.17, in Ubuntu 16.04 LTS before 1.2.15ubuntu0.2, and in Ubuntu 16.10 before 1.3.2ubuntu0.1 al…
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.07248 · Published 2017-12-05 · No fix listed CWE-295
Priority LOW 37
APT before 1.0.9 does not verify downloaded files if they have been modified as indicated using the If-Modified-Since header, which has unspecified impact and attack vectors.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01854 · Published 2014-11-03 · No fix listed
Priority LOW 35
Buffer overflow in the HTTP transport code in apt-get in APT 1.0.1 and earlier allows man-in-the-middle attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted URL.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.02594 · Published 2014-09-30 · No fix listed CWE-119
Priority LOW 34
APT before 1.0.9 does not "invalidate repository data" when moving from an unauthenticated to authenticated state, which allows remote attackers to have unspecified impact via crafted repository data.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.02084 · Published 2014-11-03 · No fix listed CWE-20
Priority LOW 28
The mirror:// method implementation in Advanced Package Tool (APT) 1.6.x before 1.6.4 and 1.7.x before 1.7.0~alpha3 mishandles gpg signature verification for the InRelease file of a fallback mirror, aka mirrorfail.
CVSS 3.0MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00954 · Published 2018-08-21 · No fix listed CWE-347
Priority LOW 26
APT had several integer overflows and underflows while parsing .deb packages, aka GHSL-2020-168 GHSL-2020-169, in files apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc.
CVSS 3.1MEDIUM 5.7· Local · High privileges · No interaction · EPSS 0.00378 · Published 2020-12-10 · Fixed in 1.2.32ubuntu0.2, 1.6.12ubuntu0.2 +2 CWE-190
Priority LOW 23
apt 0.8.16, 0.9.7, and possibly other versions does not properly handle InRelease files, which allows man-in-the-middle attackers to modify packages before installation via unknown vectors, possibly related to integrity…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01343 · Published 2013-03-21 · No fix listed CWE-20
Priority LOW 23
APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01686 · Published 2011-07-27 · No fix listed CWE-20
Priority LOW 22
APT before 1.0.4 does not properly validate source packages, which allows man-in-the-middle attackers to download and install Trojan horse packages by removing the Release signature.
CVSS 2.0MEDIUM 4.0· Network · No auth · Interaction — · EPSS 0.0157 · Published 2014-06-17 · No fix listed CWE-20
Priority LOW 20
It was found that apt-key in apt, all versions, do not correctly validate gpg keys with the master keyring, leading to a potential man-in-the-middle attack.
CVSS 3.1LOW 3.7· Network · No auth · No interaction · EPSS 0.01191 · Published 2019-11-25 · No fix listed CWE-347
Priority LOW 17
The changelog command in Apt before 1.0.9.2 allows local users to write to arbitrary files via a symlink attack on the changelog file.
CVSS 2.0LOW 3.6· Local · No auth · Interaction — · EPSS 0.00386 · Published 2014-10-15 · No fix listed CWE-59
Priority LOW 17
APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import keyrings, relies on GnuPG argument order and does not check GPG subkeys, which might allow remote attackers to install Trojan h…
CVSS 2.0LOW 2.6· Network · No auth · Interaction — · EPSS 0.01685 · Published 2012-06-19 · No fix listed CWE-20
Priority LOW 17
APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import keyrings, relies on GnuPG argument order and does not check GPG subkeys, which might allow remote attackers to install altered…
CVSS 2.0LOW 2.6· Network · No auth · Interaction — · EPSS 0.02186 · Published 2012-06-19 · No fix listed CWE-20
Priority LOW 15
methods/https.cc in apt before 0.8.11 accepts connections when the certificate host name fails validation and Verify-Host is enabled, which allows man-in-the-middle attackers to obtain repository credentials via unspecif…
CVSS 2.0LOW 2.6· Network · No auth · Interaction — · EPSS 0.00815 · Published 2014-02-28 · No fix listed CWE-200
Priority LOW 14
Various memory and file descriptor leaks were found in apt-python files python/arfile.cc, python/tag.cc, python/tarfile.cc, aka GHSL-2020-170.
CVSS 3.1LOW 2.8· Local · Low privileges · User interaction · EPSS 0.00395 · Published 2020-12-10 · Fixed in 1.1.0~beta1ubuntu0.16.04.10, 1.6.5ubuntu0.4 +2 CWE-772
Priority LOW 11
Apt 0.8.16~exp5ubuntu13.x before 0.8.16~exp5ubuntu13.6, 0.8.16~exp12ubuntu10.x before 0.8.16~exp12ubuntu10.7, and 0.9.7.5ubuntu5.x before 0.9.7.5ubuntu5.2, as used in Ubuntu, uses world-readable permissions for /var/log/…
CVSS 2.0LOW 2.1· Local · No auth · Interaction — · EPSS 0.00352 · Published 2012-12-26 · No fix listed CWE-200