Cross-site scripting in EC-CUBE
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.
Why it matters now
EPSS 0.01557 75th percentileScored 2026-11-07
Fix Fixed ec-cube/ec-cube (Packagist): 4.0.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| EC-CUBE CO.,LTD. | EC-CUBE | EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) | — | No fix listed | CNA |
| — | ec-cube/ec-cube (Packagist) | 3.0.0 – 3.0.18-p2 | — | No fix listed | GHSA-vrpv-26fm-7vf7 |
| — | ec-cube/ec-cube (Packagist) | 4.0.0 to before 4.0.6 | 4.0.6 | Patch available | GHSA-vrpv-26fm-7vf7 |
- EC-CUBE VendorEC-CUBE CO.,LTD. Affected EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) Fixed in — No fix listed CNA
- ec-cube/ec-cube (Packagist) Vendor— Affected 3.0.0 – 3.0.18-p2 Fixed in — No fix listed GHSA-vrpv-26fm-7vf7
- ec-cube/ec-cube (Packagist) Vendor— Affected 4.0.0 to before 4.0.6 Fixed in 4.0.6 Patch available GHSA-vrpv-26fm-7vf7
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ec-cube:ec-cube:*:*:*:*:*:*:*:* | 3.0.0 to before 3.0.18; 4.0.0 to before 4.0.5 | Vulnerable | EC-CUBE CO.,LTD. |
| cpe:2.3:a:ec-cube:ec-cube:3.0.18:-:*:*:*:*:*:* | 3.0.18 | Vulnerable | EC-CUBE CO.,LTD. |
| cpe:2.3:a:ec-cube:ec-cube:3.0.18:p1:*:*:*:*:*:* | 3.0.18 p1 | Vulnerable | EC-CUBE CO.,LTD. |
| cpe:2.3:a:ec-cube:ec-cube:4.0.5:-:*:*:*:*:*:* | 4.0.5 | Vulnerable | EC-CUBE CO.,LTD. |
- cpe:2.3:a:ec-cube:ec-cube:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.18; 4.0.0 to before 4.0.5 Vulnerable ·EC-CUBE CO.,LTD.
- cpe:2.3:a:ec-cube:ec-cube:3.0.18:-:*:*:*:*:*:* Versions 3.0.18 Vulnerable ·EC-CUBE CO.,LTD.
- cpe:2.3:a:ec-cube:ec-cube:3.0.18:p1:*:*:*:*:*:* Versions 3.0.18 p1 Vulnerable ·EC-CUBE CO.,LTD.
- cpe:2.3:a:ec-cube:ec-cube:4.0.5:-:*:*:*:*:*:* Versions 4.0.5 Vulnerable ·EC-CUBE CO.,LTD.
Remediation
- Fix · GHSA-vrpv-26fm-7vf7 ec-cube/ec-cube (Packagist) Fixed in 4.0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-20750
- 2026-10-03 Alias added: GHSA-vrpv-26fm-7vf7
References
More EC-CUBE CO.,LTD. Ec-cube vulnerabilities
- TI-2020-04559 Path traversal in EC-CUBE CVSS 3.1HIGH 8.1
- TI-2023-25304 Code injection in EC-CUBE 4 series CVSS 3.1HIGH 7.2
- TI-2021-04004 Improper access control vulnerability in EC-CUBE 4.0.6 (EC-CUBE 4 series) allows a remote… CVSS 3.1HIGH 7.5
- TI-2020-04641 Improper input validation in EC-CUBE CVSS 3.1HIGH 7.5
- TI-2008-04745 SQL injection vulnerability in LOCKON CO.,LTD. CVSS 2.0HIGH 7.5
- TI-2008-04326 SQL injection vulnerability in EC-CUBE Ver2 2.1.2a and earlier, and Ver2 RC 2.3.0-rc1 and… CVSS 2.0HIGH 7.5
Sources
- CVE-2021-20750 · CVE Program
- CVE-2021-20750 · NVD
- FIRST EPSS
- GHSA-vrpv-26fm-7vf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences