Records5All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high1CVSS 7.0–8.9
Exploited now
Ejs records in CISA KEVNo Ejs vulnerabilities are listed in CISA KEV.
Components
Products in the NVD configurations · select one to filter the recordsPriority HIGH 82
ejs v3.1.9 is vulnerable to server-side template injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05552 · Published 2023-05-04 · No fix listed CWE-74
Priority HIGH 67
The ejs (aka Embedded JavaScript templates) package 3.1.6 for Node.js allows server-side template injection in settings[view options][outputFunctionName].
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.32808 · Published 2022-04-25 · Partial fix · 3.1.7 CWE-94
Priority MEDIUM 51
nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0638 · Published 2017-11-17 · Fixed in 2.5.5 CWE-20
Priority LOW 37
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.02267 · Published 2017-11-17 · Fixed in 2.5.5 CWE-20
Priority LOW 30
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01233 · Published 2017-11-17 · Fixed in 2.5.5 CWE-79
Open these records in search →