The Shield Security – Smart Bot Blocking & Intrusion Prevention Security plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 18.5.9 via the render_action_template parameter.
The Shield Security plugin for WordPress is vulnerable to stored Cross-Site Scripting in versions up to, and including, 17.0.17 via the 'User-Agent' header.
CVSS 3.1HIGH 7.2·Network·No auth·No interaction·EPSS 0.93046·Published 2023-06-09·Fixed in 17.0.18CWE-79
The Shield Security WordPress plugin before 20.0.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege us…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.01551·Published 2024-08-26·Fixed in 20.0.6CWE-79
The Shield Security WordPress plugin before 13.0.6 does not sanitise and escape admin notes, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed.
CVSS 3.1MEDIUM 4.8·Network·High privileges·User interaction·EPSS 0.00598·Published 2022-02-21·Fixed in 13.0.6CWE-79
The Shield Security plugin for WordPress is vulnerable to Missing Authorization on the 'theme-plugin-file' AJAX action in versions up to, and including, 17.0.17.
CVSS 3.1MEDIUM 4.3·Network·Low privileges·No interaction·EPSS 0.0055·Published 2023-06-09·Fixed in 17.0.18CWE-862