Read the docs
TI-2024-06774 Aliases CVE-2024-7313GHSA-c84x-657q-q6vq

Shield Security < 20.0.6 - Reflected XSS

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Shield Security WordPress plugin before 20.0.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01551 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Shield Security (Unknown): 20.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownShield Securitybefore 20.0.620.0.6Patch availableCNA
  • Shield Security VendorUnknown Affected before 20.0.6 Fixed in 20.0.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getshieldsecurity:shield_security:*:*:*:*:*:wordpress:*:*before 20.0.6VulnerableGetshieldsecurity
  • cpe:2.3:a:getshieldsecurity:shield_security:*:*:*:*:*:wordpress:*:* Versions before 20.0.6 Vulnerable ·Getshieldsecurity

Remediation

  • Fix · CNA Shield Security (Unknown) Fixed in 20.0.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-7313
  2. 2026-10-03 Alias added: GHSA-c84x-657q-q6vq

References

  • TI-2023-06390 Shield Security – Smart Bot Blocking & Intrusion Prevention Security <= 18.5.9 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
  • TI-2023-00939 Shield Security <= 17.0.17 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
  • TI-2024-14764 WordPress Shield Security Plugin <= 18.5.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2022-00148 Shield Security < 13.0.6 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
  • TI-2023-00940 Shield Security <= 17.0.17 - Missing Authorization CVSS 3.1MEDIUM 4.3

Sources