An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-95.
Summary
An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the way it validates XML files. If a victim user loads a maliciously crafted XML file containing Python code, the code will be passed to an eval function, causing it to execute on the user's machine.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Guardrails AI | guardrails | 0.2.9 to before 0.5.10 | 0.5.10 | Patch available | CNA |
| — | guardrails-ai (PyPI) | 0.2.9 to before 0.5.10 | 0.5.10 | Patch available | GHSA-w392-75q8-vr67 |
- guardrails VendorGuardrails AI Affected 0.2.9 to before 0.5.10 Fixed in 0.5.10 Patch available CNA
- guardrails-ai (PyPI) Vendor— Affected 0.2.9 to before 0.5.10 Fixed in 0.5.10 Patch available GHSA-w392-75q8-vr67
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:guardrailsai:guardrails:*:*:*:*:*:*:*:* | — | — | Guardrails AI |
- cpe:2.3:a:guardrailsai:guardrails:*:*:*:*:*:*:*:* Versions — — ·Guardrails AI
Remediation
- Fix · CNA guardrails (Guardrails AI) Fixed in 0.5.10
- Fix · GHSA-w392-75q8-vr67 guardrails-ai (PyPI) Fixed in 0.5.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45858
- 2026-10-03 Alias added: GHSA-w392-75q8-vr67
References
More Guardrails AI vulnerabilities
- TI-2026-33119 Malware in 42 @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys KEVCVSS 3.1CRITICAL 9.6
- TI-2026-33495 Malicious code in guardrails-ai 0.10.1 (supply chain compromise) CVSS 3.1CRITICAL 9.6
Sources
- CVE-2024-45858 · CVE Program
- CVE-2024-45858 · NVD
- FIRST EPSS
- GHSA-w392-75q8-vr67 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences