The Hummingbird WordPress plugin before 3.4.2 does not validate the generated file path for page cache files before writing them, leading to a path traversal vulnerability in the page cache module.
CVSS 3.1CRITICAL 9.8·Network·No auth·No interaction·EPSS 0.01119·Published 2023-04-10·Fixed in 3.4.2CWE-22
Missing Authorization vulnerability in WPMU DEV - Your All-in-One WordPress Platform Hummingbird hummingbird-performance.This issue affects Hummingbird: from n/a through <= 3.9.1.
The Hummingbird WordPress plugin before 3.3.2 does not sanitise and escape the Config Name, which could allow high privilege users, such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capa…
CVSS 3.1MEDIUM 4.8·Network·High privileges·User interaction·EPSS 0.02793·Published 2022-04-18·Fixed in 3.3.2CWE-79
Missing Authorization vulnerability in WPMU DEV - Your All-in-One WordPress Platform Hummingbird hummingbird-performance.This issue affects Hummingbird: from n/a through <= 3.7.3.