Read the docs

nextscripts

Records12All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high4CVSS 7.0–8.9

Exploited now

nextscripts records in CISA KEV

No nextscripts vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

12 records

Priority MEDIUM 40

Deserialization of Untrusted Data vulnerability in NextScripts NextScripts social-networks-auto-poster-facebook-twitter-g allows Object Injection.This issue affects NextScripts: from n/a through <= 4.4.7.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00421 Published 2026-03-05 No fix listed CWE-502
Priority LOW 35

The NextScripts: Social Networks Auto-Poster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `[nxs_fbembed]` shortcode in all versions up to, and including, 4.4.6.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.04244 Published 2026-03-10 No fix listed CWE-79
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in NextScripts NextScripts social-networks-auto-poster-facebook-twitter-g allows DOM-Based XSS.This issue affects NextScr…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00311 Published 2024-07-22 No fix listed CWE-79
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in NextScripts NextScripts: Social Networks Auto-Poster allows Reflected XSS.This issue affects NextScripts: Social Netwo…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00403 Published 2023-12-15 No fix listed CWE-79
Priority LOW 30

The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.24 does not sanitise and escape logged requests before outputting them in the related admin dashboard, leading to an Unauthenticated Stored Cross-S…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01334 Published 2022-02-01 Fixed in 4.3.24 CWE-79
Priority LOW 29

The NextScripts: Social Networks Auto-Poster <= 4.3.20 WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the $_REQUEST['page'] parameter which is echoed out on inc/nxs_class_snap.php by supplying the a…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00873 Published 2021-11-01 No fix listed CWE-79
Priority LOW 29

The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.25 does not have CSRF check in place when deleting items, allowing attacker to make a logged in admin delete arbitrary posts via a CSRF attack

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00531 Published 2022-02-01 Fixed in 4.3.25 CWE-352
Priority LOW 29

The NextScripts: Social Networks Auto-Poster plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on multiple user privilege/security functions provided in versions up to, and inclu…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00501 Published 2024-10-16 No fix listed CWE-284
Priority LOW 27

The NextScripts: Social Networks Auto-Poster plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the HTTP_USER_AGENT header in all versions up to, and including, 4.4.3 due to insufficient input sanitiza…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00389 Published 2024-05-22 No fix listed CWE-79
Open these records in search →