NextScripts: Social Networks Auto-Poster < 4.3.25 - Arbitrary Post Deletion via CSRF
Priority LOW 29CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.25 does not have CSRF check in place when deleting items, allowing attacker to make a logged in admin delete arbitrary posts via a CSRF attack
Why it matters now
EPSS 0.00531 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed NextScripts: Social Networks Auto-Poster (Unknown): 4.3.25
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | NextScripts: Social Networks Auto-Poster | 4.3.25 to before 4.3.25 | 4.3.25 | Patch available | CNA |
- NextScripts: Social Networks Auto-Poster VendorUnknown Affected 4.3.25 to before 4.3.25 Fixed in 4.3.25 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextscripts:social_networks_auto_poster:*:*:*:*:*:wordpress:*:* | before 4.3.25 | Vulnerable | nextscripts |
- cpe:2.3:a:nextscripts:social_networks_auto_poster:*:*:*:*:*:wordpress:*:* Versions before 4.3.25 Vulnerable ·nextscripts
Remediation
- Fix · CNA NextScripts: Social Networks Auto-Poster (Unknown) Fixed in 4.3.25
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25072
- 2026-10-03 Alias added: GHSA-v2v6-4445-2f8x
References
More nextscripts Social Networks Auto Poster vulnerabilities
- TI-2024-01944 NextScripts: Social Networks Auto-Poster <= 4.4.3 - Authenticated(Subscriber+) Sensitive Information Exposure CVSS 3.1HIGH 8.5
- TI-2024-24790 WordPress NextScripts plugin <= 4.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-26842 WordPress NextScripts Plugin <= 4.4.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2021-07254 NextScripts: Social Networks Auto-Poster < 4.3.24 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2019-07283 The social-networks-auto-poster-facebook-twitter-g plugin before 4.2.8 for WordPress has… CVSS 3.1MEDIUM 6.1
- TI-2021-15963 NextScripts: Social Networks Auto-Poster <= 4.3.20 Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-25072 · CVE Program
- CVE-2021-25072 · NVD
- FIRST EPSS
- GHSA-v2v6-4445-2f8x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences