Read the docs
TI-2021-07254 Aliases CVE-2021-24975GHSA-gpxw-6663-f9cg

NextScripts: Social Networks Auto-Poster < 4.3.24 - Unauthenticated Stored XSS

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.24 does not sanitise and escape logged requests before outputting them in the related admin dashboard, leading to an Unauthenticated Stored Cross-Site Scripting issue

Why it matters now

EPSS 0.01334 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed NextScripts: Social Networks Auto-Poster (Unknown): 4.3.24

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNextScripts: Social Networks Auto-Poster4.3.24 to before 4.3.244.3.24Patch availableCNA
  • NextScripts: Social Networks Auto-Poster VendorUnknown Affected 4.3.24 to before 4.3.24 Fixed in 4.3.24 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nextscripts:social_networks_auto_poster:*:*:*:*:*:wordpress:*:*before 4.3.24Vulnerablenextscripts
  • cpe:2.3:a:nextscripts:social_networks_auto_poster:*:*:*:*:*:wordpress:*:* Versions before 4.3.24 Vulnerable ·nextscripts

Remediation

  • Fix · CNA NextScripts: Social Networks Auto-Poster (Unknown) Fixed in 4.3.24

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24975
  2. 2026-10-03 Alias added: GHSA-gpxw-6663-f9cg

References

  • TI-2024-01944 NextScripts: Social Networks Auto-Poster <= 4.4.3 - Authenticated(Subscriber+) Sensitive Information Exposure CVSS 3.1HIGH 8.5
  • TI-2024-24790 WordPress NextScripts plugin <= 4.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-26842 WordPress NextScripts Plugin <= 4.4.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2019-07283 The social-networks-auto-poster-facebook-twitter-g plugin before 4.2.8 for WordPress has… CVSS 3.1MEDIUM 6.1
  • TI-2021-15963 NextScripts: Social Networks Auto-Poster <= 4.3.20 Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2021-07350 NextScripts: Social Networks Auto-Poster < 4.3.25 - Arbitrary Post Deletion via CSRF CVSS 3.1MEDIUM 6.5
See all 9 →

Sources