The ND Shortcodes WordPress plugin before 7.0 does not validate some shortcode attributes before using them to generate paths passed to include function/s, allowing any authenticated users such as subscriber to perform L…
CVSS 3.1HIGH 8.8·Network·Low privileges·No interaction·EPSS 0.01683·Published 2023-07-04·Fixed in 7.0
The ND Shortcodes WordPress plugin before 7.0 does not validate and escape numerous of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the co…
CVSS 3.1MEDIUM 5.4·Network·Low privileges·User interaction·EPSS 0.00444·Published 2023-07-04·Fixed in 7.0
The ND Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's upload feature in all versions up to, and including, 7.5 due to insufficient input sanitization and output escaping.