The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) by sending a specifically crafted OPC UA message with a special OPC UA NodeID, when the requested memory allocation exceeds the v8’s memory l…
CVSS 3.1HIGH 7.5·Network·No auth·No interaction·EPSS 0.01321·Published 2022-08-23·Fixed in 2.74.0CWE-770
The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription paramet…
CVSS 3.1HIGH 7.5·Network·No auth·No interaction·EPSS 0.01671·Published 2022-08-24·Fixed in 2.74.0CWE-400
The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions.
CVSS 3.1HIGH 7.5·Network·No auth·No interaction·EPSS 0.01461·Published 2022-08-23·Fixed in 2.74.0CWE-1284