Denial of service (DoS) in node-opcua
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) by sending a specifically crafted OPC UA message with a special OPC UA NodeID, when the requested memory allocation exceeds the v8’s memory limit.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | node-opcua | before 2.74.0 | 2.74.0 | Patch available | CNA |
| — | node-opcua (npm) | before 2.74.0 | 2.74.0 | Patch available | GHSA-qpgc-xh7j-52q8 |
- node-opcua Vendor— Affected before 2.74.0 Fixed in 2.74.0 Patch available CNA
- node-opcua (npm) Vendor— Affected before 2.74.0 Fixed in 2.74.0 Patch available GHSA-qpgc-xh7j-52q8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:node-opcua_project:node-opcua:*:*:*:*:*:node.js:*:* | before 2.74.0 | Vulnerable | Node-opcua Project |
- cpe:2.3:a:node-opcua_project:node-opcua:*:*:*:*:*:node.js:*:* Versions before 2.74.0 Vulnerable ·Node-opcua Project
Remediation
- Fix · CNA node-opcua Fixed in 2.74.0
- Fix · GHSA-qpgc-xh7j-52q8 node-opcua (npm) Fixed in 2.74.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
node-opcua 2.74.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-05601 Denial of service (DoS) in node-opcuaPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25231
- 2026-10-03 Alias added: GHSA-qpgc-xh7j-52q8
References
More Node-opcua Project Node-opcua vulnerabilities
- TI-2022-08252 Denial of service (DoS) in node-opcua CVSS 3.1HIGH 7.5
- TI-2022-05601 Denial of service (DoS) in node-opcua CVSS 3.1HIGH 7.5
Sources
- CVE-2022-25231 · CVE Program
- CVE-2022-25231 · NVD
- FIRST EPSS
- GHSA-qpgc-xh7j-52q8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences