Denial of service (DoS) in node-opcua
Priority LOW 36CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) when bypassing the limitations for excessive memory consumption by sending multiple CloseSession requests with the deleteSubscription parameter equal to False.
Why it matters now
EPSS 0.01671 76th percentileScored 2026-11-07
Fix Fixed node-opcua: 2.74.0node-opcua (npm): 2.74.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | node-opcua | before 2.74.0 | 2.74.0 | Patch available | CNA |
| — | node-opcua (npm) | before 2.74.0 | 2.74.0 | Patch available | GHSA-vh4f-fgpp-x8x2 |
- node-opcua Vendor— Affected before 2.74.0 Fixed in 2.74.0 Patch available CNA
- node-opcua (npm) Vendor— Affected before 2.74.0 Fixed in 2.74.0 Patch available GHSA-vh4f-fgpp-x8x2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:node-opcua_project:node-opcua:*:*:*:*:*:node.js:*:* | before 2.74.0 | Vulnerable | Node-opcua Project |
- cpe:2.3:a:node-opcua_project:node-opcua:*:*:*:*:*:node.js:*:* Versions before 2.74.0 Vulnerable ·Node-opcua Project
Remediation
- Fix · CNA node-opcua Fixed in 2.74.0
- Fix · GHSA-vh4f-fgpp-x8x2 node-opcua (npm) Fixed in 2.74.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24375
- 2026-10-03 Alias added: GHSA-vh4f-fgpp-x8x2
References
Patch 3
More Node-opcua Project Node-opcua vulnerabilities
- TI-2022-08944 Denial of service (DoS) in node-opcua CVSS 3.1HIGH 7.5
- TI-2022-05601 Denial of service (DoS) in node-opcua CVSS 3.1HIGH 7.5
Sources
- CVE-2022-24375 · CVE Program
- CVE-2022-24375 · NVD
- FIRST EPSS
- GHSA-vh4f-fgpp-x8x2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences