Cross-site request forgery in omniauth ruby gem
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.
Summary
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | omniauth ruby gem | All versions | — | No fix listed | CNA |
| — | omniauth (RubyGems) | before 2.0.0 | 2.0.0 | Patch available | GHSA-ww4x-rwq6-qpgf |
- omniauth ruby gem Vendor— Affected All versions Fixed in — No fix listed CNA
- omniauth (RubyGems) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-ww4x-rwq6-qpgf
Remediation
- Fix · GHSA-ww4x-rwq6-qpgf omniauth (RubyGems) Fixed in 2.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2015-9284
- 2026-10-03 Alias added: GHSA-ww4x-rwq6-qpgf
References
Patch 2
Advisory 3
Other 6
- https://github.com/omniauth/omniauth/issues/1031
- https://github.com/rubysec/ruby-advisory-db/commit/aef9f623c0be838234d53baf18977564804da397
- https://github.com/omniauth/omniauth
- https://github.com/omniauth/omniauth/releases/tag/v1.9.2
- https://github.com/omniauth/omniauth/releases/tag/v2.0.0
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth/CVE-2015-9284.yml
More Omniauth vulnerabilities
- TI-2020-18798 lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value. CVSS 3.1CRITICAL 9.8
- TI-2017-13284 In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly… CVSS 3.1HIGH 7.5
Sources
- CVE-2015-9284 · CVE Program
- CVE-2015-9284 · NVD
- FIRST EPSS
- GHSA-ww4x-rwq6-qpgf · GitHub Advisory Database · CC BY 4.0
- CVE-2015-9284 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences