Cross-site scripting in opencart/opencart
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
This affects versions of the package opencart/opencart from 4.0.0.0 and before 4.1.0.0. A reflected XSS issue was identified in the directory parameter of admin common/filemanager.list route. An attacker could obtain a user's token by tricking the user to click on a maliciously crafted URL. The user is then prompted to login and redirected again upon authentication with the payload automatically executing. If the attacked user has admin privileges, this vulnerability could be used as the start of a chain of exploits like Zip Slip or arbitrary file write vulnerabilities in the admin functionality. **Notes:** 1) This is only exploitable if the attacker knows the name or path of the admin directory. The name of the directory is "admin" by default but there is a pop-up in the dashboard warning users to rename it. 2) The fix for this vulnerability is incomplete. The redirect is removed so that it is not possible for an attacker to control the redirect post admin login anymore, but it is still possible to exploit this issue in admin if the user is authenticated as an admin already.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | opencart/opencart | 4.0.0.0 to before 4.1.0.0 | 4.1.0.0 | Patch available | CNA |
| — | opencart/opencart (Packagist) | 4.0.0.0 and later | — | No fix listed | GHSA-pqhq-77pw-763c |
- opencart/opencart Vendor— Affected 4.0.0.0 to before 4.1.0.0 Fixed in 4.1.0.0 Patch available CNA
- opencart/opencart (Packagist) Vendor— Affected 4.0.0.0 and later Fixed in — No fix listed GHSA-pqhq-77pw-763c
Remediation
- Fix · CNA opencart/opencart Fixed in 4.1.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21516
- 2026-10-03 Alias added: GHSA-pqhq-77pw-763c
References
More Opencart vulnerabilities
- TI-2023-21572 OpenCart CMS v4.0.2.2 was discovered to lack a protective mechanism on its login page… CVSS 3.1CRITICAL 9.8
- TI-2024-38428 OpenCart Core 4.0.2.3 SQL Injection via search Parameter CVSS 4.0HIGH 8.8
- TI-2023-25651 An issue discovered in OpenCart 4.0.0.0 to 4.0.2.3 allows authenticated backend users… CVSS 3.1HIGH 8.8
- TI-2023-02171 Improper input validation in Opencart CVSS 3.1HIGH 8.8
- TI-2024-14270 SQL injection in opencart/opencart CVSS 3.1HIGH 8.1
- TI-2024-24380 OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function. CVSS 3.1HIGH 7.2
Sources
- CVE-2024-21516 · CVE Program
- CVE-2024-21516 · NVD
- FIRST EPSS
- GHSA-pqhq-77pw-763c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences