Read the docs

Thenewsletterplugin

Records10All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high0CVSS 7.0–8.9

Exploited now

Thenewsletterplugin records in CISA KEV

No Thenewsletterplugin vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

10 records

Priority MEDIUM 55

The Newsletter WordPress plugin before 8.8.2 does not sanitise and escape some of its Subscription settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when t…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00257 Published 2025-06-03 Fixed in 8.8.2 CWE-79
TI-2025-03152 CVE-2025-3583 · GHSA-4grv-gh63-6248

Newsletter < 8.7.1 - Admin+ Stored XSS

Priority MEDIUM 55

The Newsletter WordPress plugin before 8.7.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00315 Published 2025-05-05 Fixed in 8.7.1 CWE-79
Priority MEDIUM 55

The Newsletter WordPress plugin before 8.85 does not sanitise and escape some of its Form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00269 Published 2025-06-09 Fixed in 8.85 CWE-79
Priority MEDIUM 55

The Newsletter WordPress plugin before 8.8.5 does not validate and escape some of its Widget options before outputting them back in a page/post where the block is embed, which could allow high privilege users such as adm…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00269 Published 2025-06-09 Fixed in 8.8.5 CWE-79
Priority LOW 31

The Newsletter WordPress plugin before 7.4.5 does not sanitize and escape the $_SERVER['REQUEST_URI'] before echoing it back in admin pages.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01941 Published 2022-06-13 Fixed in 7.4.5 CWE-79
Priority LOW 30

A Reflected Authenticated Cross-Site Scripting (XSS) vulnerability in the Newsletter plugin before 6.8.2 for WordPress allows remote attackers to trick a victim into submitting a tnpc_render AJAX request containing eithe…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00865 Published 2021-01-01 No fix listed CWE-79
Priority LOW 29

The Newsletter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'newsletter_form' shortcode in versions up to, and including, 7.8.9 due to insufficient input sanitization and output escaping on u…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00508 Published 2023-09-07 No fix listed CWE-79
Priority LOW 28

The Newsletter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'np1' parameter in all versions up to, and including, 8.3.4 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00291 Published 2024-06-05 No fix listed CWE-79
Priority LOW 23

The Newsletter WordPress plugin before 7.4.6 does not escape and sanitise the preheader_text setting, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when the unfilteredhtml is disal…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00588 Published 2022-06-20 Fixed in 7.4.6 CWE-79
Open these records in search →