Newsletter < 8.8.5 - Admin+ Stored XSS via Widget
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Newsletter WordPress plugin before 8.8.5 does not validate and escape some of its Widget options before outputting them back in a page/post where the block is embed, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Newsletter | before 8.8.5 | 8.8.5 | Patch available | CNA |
- Newsletter VendorUnknown Affected before 8.8.5 Fixed in 8.8.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thenewsletterplugin:newsletter:*:*:*:*:*:wordpress:*:* | before 8.8.5 | Vulnerable | Thenewsletterplugin |
- cpe:2.3:a:thenewsletterplugin:newsletter:*:*:*:*:*:wordpress:*:* Versions before 8.8.5 Vulnerable ·Thenewsletterplugin
Remediation
- Fix · CNA Newsletter (Unknown) Fixed in 8.8.5
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3581
- 2026-10-03 Alias added: GHSA-f9xh-499r-w9qx
References
More Thenewsletterplugin Newsletter vulnerabilities
- TI-2025-03153 Newsletter < 8.8.2 - Admin+ Stored XSS via Subscription CVSS 3.1MEDIUM 4.8
- TI-2025-03152 Newsletter < 8.7.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2025-03151 Newsletter < 8.8.5 - Admin+ Stored XSS via Form CVSS 3.1MEDIUM 4.8
- TI-2022-01622 Newsletter < 7.4.5 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-12513 Cross-site scripting in Stefano Lissa & The Newsletter Team Newsletter CVSS 3.1MEDIUM 6.1
- TI-2020-18376 A Reflected Authenticated Cross-Site Scripting (XSS) vulnerability in the Newsletter… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-3581 · CVE Program
- CVE-2025-3581 · NVD
- FIRST EPSS
- GHSA-f9xh-499r-w9qx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences