league/commonmark versions before 2.9.1 contain multiple denial of service vulnerabilities in fenced code block detection, reference link label lookup, and emphasis delimiter processing that perform super-linear work on…
CVSS 4.0HIGH 8.7·Network·No auth·No interaction·EPSS 0.00493·Published 2026-09-07·Fixed in 2.9.1CWE-407
The league/commonmark (thephpleague/commonmark) library in versions >= 1.5.0 and < 2.9.1 contains quadratic parsing complexity in its SmartPunctExtension and AttributesExtension.
CVSS 4.0HIGH 8.7·Network·No auth·No interaction·EPSS 0.00515·Published 2026-09-07·Fixed in 2.9.1CWE-407
commonmark versions from 1.5.0 before 2.10.0 contain a denial of service vulnerability in the AttributesExtension when processing distinctly-named attributes.
CVSS 4.0HIGH 8.7·Network·No auth·No interaction·EPSS 0.00493·Published 2026-09-07·Fixed in 2.10.0CWE-407
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via…
CVSS 3.0MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.01863·Published 2018-12-30·Fixed in 0.18.1CWE-79
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library before 0.18.3 allows remote attackers to insert unsafe links into HTML by using double-encoded HTML entities that are not properly escaped dur…
CVSS 3.0MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.0105·Published 2019-03-24·Fixed in 0.18.3CWE-79