Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library before…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library before 0.18.3 allows remote attackers to insert unsafe links into HTML by using double-encoded HTML entities that are not properly escaped during rendering, a different vulnerability than CVE-2018-20583.
Why it matters now
EPSS 0.0105 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed league/commonmark (Packagist): 0.18.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | league/commonmark (Packagist) | before 0.18.3 | 0.18.3 | Patch available | GHSA-3v43-877x-qgmq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- league/commonmark (Packagist) Vendor— Affected before 0.18.3 Fixed in 0.18.3 Patch available GHSA-3v43-877x-qgmq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thephpleague:commonmark:*:*:*:*:*:*:*:* | before 0.18.3 | Vulnerable | thephpleague |
- cpe:2.3:a:thephpleague:commonmark:*:*:*:*:*:*:*:* Versions before 0.18.3 Vulnerable ·thephpleague
Remediation
- Fix · GHSA-3v43-877x-qgmq league/commonmark (Packagist) Fixed in 0.18.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10010
- 2026-10-03 Alias added: GHSA-3v43-877x-qgmq
References
Advisory 3
More thephpleague Commonmark vulnerabilities
- TI-2026-59138 league/commonmark before 2.9.1 Denial of Service via parsing CVSS 4.0HIGH 8.7
- TI-2026-59137 commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes CVSS 4.0HIGH 8.7
- TI-2026-59136 commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes CVSS 4.0HIGH 8.7
- TI-2026-59139 commonmark before 2.9.1 XSS via AttributesExtension form feed bypass CVSS 4.0MEDIUM 6.9
- TI-2026-25753 league/commonmark has an embed extension allowed_domains bypass CVSS 4.0MEDIUM 6.3
- TI-2018-14605 Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2019-10010 · CVE Program
- CVE-2019-10010 · NVD
- FIRST EPSS
- GHSA-3v43-877x-qgmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences