Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).
Why it matters now
EPSS 0.01863 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed league/commonmark (Packagist): 0.18.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | league/commonmark (Packagist) | 0.15.6 to before 0.18.1 | 0.18.1 | Patch available | GHSA-qx76-c53f-5c7q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- league/commonmark (Packagist) Vendor— Affected 0.15.6 to before 0.18.1 Fixed in 0.18.1 Patch available GHSA-qx76-c53f-5c7q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:thephpleague:commonmark:*:*:*:*:*:*:*:* | 0.15.6 – 0.18.0 | Vulnerable | thephpleague |
- cpe:2.3:a:thephpleague:commonmark:*:*:*:*:*:*:*:* Versions 0.15.6 – 0.18.0 Vulnerable ·thephpleague
Remediation
- Fix · GHSA-qx76-c53f-5c7q league/commonmark (Packagist) Fixed in 0.18.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-20583
- 2026-10-03 Alias added: GHSA-qx76-c53f-5c7q
References
Advisory 3
More thephpleague Commonmark vulnerabilities
- TI-2026-59138 league/commonmark before 2.9.1 Denial of Service via parsing CVSS 4.0HIGH 8.7
- TI-2026-59137 commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes CVSS 4.0HIGH 8.7
- TI-2026-59136 commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes CVSS 4.0HIGH 8.7
- TI-2026-59139 commonmark before 2.9.1 XSS via AttributesExtension form feed bypass CVSS 4.0MEDIUM 6.9
- TI-2026-25753 league/commonmark has an embed extension allowed_domains bypass CVSS 4.0MEDIUM 6.3
- TI-2019-07346 Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library before… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2018-20583 · CVE Program
- CVE-2018-20583 · NVD
- FIRST EPSS
- GHSA-qx76-c53f-5c7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences